[HELP] Having problem with making calls to analog lines

I have configured a EICON Diva Server BRI card to use with asterisk. i am using trixbox to do the configurations. i cam make calls to mobile phones and isdn lines from both the soft phone(x-lite) and the IP Phone.

but my problem is that i canot make calls to analog numbers. when i call from the soft phone , it actually shows in the screen that the phone is ringing and call established. But i cannot hear the phone ringing.i tried calling one of the phone in my office.

i contacted Eicon and i did the acopy test as they requested. when i tired ringing through acopy utility , i can hear the phone ringing. which means, they said, the card is installed properly and working fine. so the problem is with the configuration files. i have no idea which file to edit.

can anyone help me with this problm. i am stuck!!!. please…
please ask if you need any more information.

thanks in advance,


if you are using xlite and have one way audio, your problem is almost certainly NAT related.

I am going to assume you have a standard setup:

(internet) – ISP – NAT router – * box – X-Lite

You need to first (since x-lite is behind the same NAT as *) turn off STUN in xlite. Then set nat=no in *. I would also recommend forwarding port 5060 and (a range you can set in rtp.conf) to *, but this is not needed if you don’t need SIP connections from outside the NAT.

Once you do this, set canreinvite=no in sip.conf in the general section

Now try having x-lite call the echo test (not sure what its exten is in trixbox). If you can talk and hear yourself, then you are set. If not then keep working.

hope that helps

Hi IronFelix,
Thank you very much for your reply. I really appreciate it.
I can’t wait to test this. But i am back home and only back to office on monday. i will post the result as soon as i did the changes.