[HELP] Concurrent use of */Zap and analog phones


#1

Hopefully, this is a quick answer and a config setting in zapata or zaptel, and I apologize in advance if this is answered elsewhere - I couldn’t find my answer on voip-info.org, and truthfully I don’t even know what to search for.

The basics - I have * running with a TDM04B connected to 4 pots lines. I have a handful of IP phones talking SIP, and trunking out the pots lines. I also have legacy analog phones. My problem is that * is not detecting that a pots line is in use from the legacy phones, and is trying to dial out over existing conversations. I’m sure this is something that can be fixed: my analog phones are a 4-line Panasonic base station with cordless remotes; this system shows lines in use and won’t let you barge (by default). I just need to configure asterisk to work the same way, and all my problems are solved.

Unfortunately, dedicating two lines to * and two to legacy is not an option.

Please help

TIA,

bsdbigot


#2

Sorry I do not think this will work now if all the lines were on the asterisk box it would know the line was in use just like on your legacy phones. I did find this on the site list but never used one

Does anyone know if there is a zapata.conf option to tell * to

listen for a dialtone before dialing?

I’ve got a couple of analog phones on a pstn line shared with a
x100p * fx line. If someone is on the analog phone and another
person initiates a call through * to use the same line, * dials
over the top of the existing conversation. Is there a way to have

  • detect dialtone before dialing?

Rich


Asterisk-Users mailing list
Asterisk-Users@lists.digium.com
http://lists.digium.com/mailman/listinfo/asterisk-users

My solution to a shared line (modem and asterisk) was to use an isolator
(somtimes called a privacy adapter)…

Basically it has two ports on one side and connectd to the line on the
other side… when either one of the ports is engaged in a call the other
port is disabled…


#3

I appreciate the input, but I’m sure there has to be a way - outside of the Panasonic, I also have GE business phones (analog) which also show line-in-use and require a double-press of the line button to barge. This should be a very simple issue (Ohm’s law), and I can’t believe that Digium wouldn’t have this ability in their TDM products - after all, the zaptel drivers report polarity changes on the line (thinking maybe that’s the problem, that I have the wires flipped through some bone-headed punchdown on my part)

(edit) Part of my logic in asserting that this must be possible is the “zap show channel X” command, which has some different outputs, based on if that channel is currently bridged (FYI, I’m on FreeBSD, so it’s possible that some of the Zaptel stuff isn’t working correctly or at all).

Excerpt with call in progress:

Channel: 4 File Descriptor: 20 Span: 2 Extension: Dialing: no Context: from_pstn Caller ID string: Destroy: 0 InAlarm: 0 Signalling Type: FXS Kewlstart Owner: Zap/4-1 Real: Zap/4-1 Callwait: <None> Threeway: <None> Confno: -1 Propagated Conference: -1 Real in conference: 0 DSP: yes Relax DTMF: no Dialing/CallwaitCAS: 0/0 Default law: ulaw Fax Handled: no Pulse phone: no Echo Cancellation: 128 taps unless TDM bridged, currently ON Actual Confinfo: Num/0, Mode/0x0000 Actual Confmute: No Actual Hookstate: Offhook

Excerpt when channel is “available”:

Channel: 4 File Descriptor: 20 Span: 2 Extension: Dialing: no Context: from_pstn Caller ID string: Destroy: 0 InAlarm: 0 Signalling Type: FXS Kewlstart Owner: <None> Real: <None> Callwait: <None> Threeway: <None> Confno: -1 Propagated Conference: -1 Real in conference: 0 DSP: no Relax DTMF: no Dialing/CallwaitCAS: 0/0 Default law: ulaw Fax Handled: no Pulse phone: no Echo Cancellation: 128 taps unless TDM bridged, currently OFF Actual Confinfo: Num/0, Mode/0x0000 Actual Confmute: No Actual Hookstate: Offhook