[HELP] compilation issues on s390 / s390x hardware


#1

Hi folks,

I ultimately want to get asterisk and festival compiled on a Linux s390 / s390x (mainframe) machine, but having compilation issues. I have tried both 2.4 and 2.6 kernel versions, and getting the exact same error and I think it’s something rather simple.

I’m trying the latest asterisk-1.2.7.1, version. Here is the complilation error I get - any ideas would be greatly appreciated. Thanks!

gcc -c -o buildinfo.o -pipe -Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -g3 -Iinclude-I…/include -D_REENTRANT -D_GNU_SOURCE -O6 -fomit-frame-pointer buildinfo.c
gcc -g3 -o asterisk -Wl,-E io.o sched.o logger.o frame.o loader.o config.o channel.o translate.o file.o say.o pbx.o cli.o md5.o term.o ulaw.o alaw.o callerid.o fskmodem.o image.o app.o cdr.o tdd.o acl.o rtp.o manager.o asterisk.o dsp.o chanvars.o indications.o autoservice.o db.o privacy.o astmm.o enum.o srv.o dns.o aescrypt.o aestab.o aeskey.o utils.o plc.o jitterbuf.o dnsmgr.o devicestate.o netsock.o slinfactory.o ast_expr2.o ast_expr2f.o cryptostub.o buildinfo.o editline/libedit.a db1-ast/libdb1.a stdtime/libtime.a -ldl -lpthread -lncurses -lm -lresolv -lssl
/usr/lib64/gcc-lib/s390x-suse-linux/3.3.3/…/…/…/…/s390x-suse-linux/bin/ld: cannot find -lssl
collect2: ld returned 1 exit status
make: *** [asterisk] Error 1


#2

have you checked that the development file for ssl are avaiable on you system ? If you have a packaging system like dep or rpm avaiable try searching for a package named libssl-dev or so.

good luck :smiley:


#3

Thanks for the suggestion on the ssl development package - that was the key.

Moving forward, and I think we are almost there, I see an issue that arch=s390 isn’t supported. This is the actual hardware that I’m trying to compile on (Linux on s390 / mainframe) and I wonder - is there a way around this to make asterisk to compile. I’m thinking that this has to work.

Thanks

gcc -pipe -Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -g3 -Iinclude -I…/include -D_REENTRANT -D_GNU_SOURCE -O6 -fomit-frame-pointer -fPIC -c -DNeedFunctionPrototypes=1 -funroll-loops -O6 -march=s390 -fPIC -DSASR -DNDEBUG -DWAV49 -I./inc src/add.c
cc1: invalid option arch=s390' make[2]: *** [src/add.o] Error 1 make[2]: Leaving directory/usr/src/asterisk-1.2.7.1/codecs/gsm’
make[1]: *** [gsm/lib/libgsm.a] Error 2
make[1]: Leaving directory `/usr/src/asterisk-1.2.7.1/codecs’
make: *** [subdirs] Error 1