[HELP] Asterisk intercepts # tones and throws a pbx-invalid


#1

In order to use a 3rd party voicemail system attached via SIP to Asterisk where most of the user input is to be confirmed by the # (pound/hash) I am searching for a method to bypass the interception of exactly this digit.
I always get
Started music on hold, class ‘default’, on SIP/…
Unable to find extension ‘’ in context 'default’
Playing 'pbx-invalid’
and the # tone won´t be forwarded to the voice mail system. This
interception seems to be stronger than any extensions.conf.


#2

This is probably occurring because you have # transfers enabled in your dialplan. In the stable version of Asterisk, you’ll need to disable this feature if you need users to be able to use the entire telephone keypad. To do so, remove the “T” flag from the Dial options. If users ordinarily need to transfer calls they dialed, consider adding a separate dialout prefix without transfers enabled. Another option would be to change your dialplan to explicitly recognize the voicemail number and not enable transfers for it.

If you’re using the CVS version of Asterisk, you can change the transfer key in features.conf. Changing it from # to ## should do what you want (# can then be used; pressing # twice quickly will initiate a blind transfer).