Graphs in the GUI break things?

Hello. I have an unusual problem i’ve never seen before. When attempting to view the “Graphs” tab I get: Tool Error: 404: Not Found. It will keep popping up until I browse to another tab. The interesting part is that after this happens, almost none of the other tabs work (give the same error), to name a few: Incoming Calls, Voice Menus, File editor, etc… I have tried recompiling things, completely formatted the hard drives and re-installed the OS and each component and recompiled. This is at least the third fresh install (testing, obviously) that it breaks on (forces me to restart asterisk to fix the issue). Now, here’s essentially what software I’m currently running:

OS: CentOS 5.1

(SVN) … old_trunk/

MySQL, etc. excluded due to irrelevance.

Thanks for taking the time to read this!

Well, I’ve yet to find a fix for this issue as of yet, so my “fix” for now, at least, is to remove the “Graphs” tab from cfgbasic.html :smile:. Worked great!Now if I can only get the CDR working like I want…

what do you use to edit cfgbasic.html? I am trying to use nano but I am unable to save the file.

what do you use to edit cfgbasic.html? I am trying to use nano but I am unable to save the file.[/quote]

I just used the internal editor in WinSCP while i had it open (logged in as root) to transfer files. You can nano it but the default owner should be root. If you’re not root, either sudo nano cfgbasic.html or just su to get root access. I ended up grabbing the AsteriskNOW revision of the gui and adding/removing panels as I wanted them to be (graphs in that revision already disabled anyway).

Thanks chevyman. I figured that out last night after hours of trying things.