Got SIP response 409 "Conflict" back from

I have 3 SIP Broadvoice accounts that I register.

Got SIP response 409 “Conflict” back from

I see this message at the console and it seems at the same time incoming calls just ring and appear to be answered according to the log but they are not really answered. The person calling just hears the ring tone.

I am behind a firewall and have 5060 and 10000-20000 are mapped to the asterisk box.

Can someone explain what a “409” response is? And what I could try to fix it?

Thanks… sooooo much.

-doug … 409-00.txt

Thanks… The spec says

“Conflicts are most likely to occur in response to requests that
create state in the network, such as REGISTER and SUBSCRIBE. The
circumstances under which a 409 response code is returned are
expected to be highly dependent on the application that the UAS

And this makes sense because when I saw the conflict “sip show registry” would not show “Registered”.

Since my registry works 99% of the time, my guess is it’s my provider who was having problems… Is that a valid assumption?

Hey Doug,

I too am having this problem. It’s idnetical to what you described above. When an incomming call hit’s my * box it takes a few seconds to get the 409 but then it unregisters form the broadvoice proxy. I tried registering to other broadvoice servers but I get the same result.

This started when we switched to covad ADSL from SBC/ATT DSL this week. Covad provided us with a Broadxent 8120-R1 router. In the router I forwarded all neccesary ports to the * server. NAT is enabled in the router and well as set to “NAT=yes” and “qualify=yes” in * on the trunks.

Have you had any luck with yours?

Tom - Chicago

Did you ever find a solution for this? I am only experiencing this with Broadvoice using Asterisk 1.4…