Google Voice

Run “make menuselect” when building and see if you’ve got the dependencies in place to install them.

Cheers.

[quote=“twinclouds”]Now I am might get somewhere but still not work. Below is the error message:
" == Using SIP RTP CoS mark 5
– Executing [18586584251@default:1] Dial(“SIP/192.168.2.135-00000001”, “gtalk/asterisk/+18586584251@voice.google.com”) in new stack
[Oct 29 22:58:31] WARNING[2279]: channel.c:5353 ast_request: No channel type registered for ‘gtalk’
[Oct 29 22:58:31] WARNING[2279]: app_dial.c:2030 dial_exec_full: Unable to create channel of type ‘gtalk’ (cause 66 - Channel not implemented)
== Everyone is busy/congested at this time (1:0/0/1)
– Auto fallthrough, channel ‘SIP/192.168.2.135-00000001’ status is ‘CHANUNAVAIL’"

But I do have gtalk.conf:

[general]
context=default
allowguests=yes
bindaddr=0.0.0.0
externip=my.ip.address.xxx

[guest]
disallow=all
allow=ulaw
context=default
connection=asterisk

Can someone point out what is wrong?[/quote]

I think based on your follow-on post that you discovered you didn’t have res_jabber or chan_gtalk loaded, which probably means they weren’t compiled for some reason or another.

I am happy to report that I eventually made gtalk working on Asterisk 1.8 installed on Dockstar, a ARM platform. However, when I installed A1.8, I cannot select gtalk channel and jabber module. I have to install iksemel first as described in michigantelephone.wordpress.com/ … tallation/. Is this normal?
Then I found the problem that I cannot register my sip softphone was because I need to set the protocol to be UDP. TCP does not work on A1.8 even though it works on A1.6 and 1.4. Finally, looks like my installation (ARM based Debian Lenny) cannot handle 8 character secret. I reduced to 5 digits and it worked. Now everything looks really good.
The config files I used are adapted from jimylongs’ files.
Thanks for all of your help.

Hi twinclouds,

I also started trying out Asterisk 1.8 on a DockStar yesterday following this thread.

I’m getting the "wrong password’ when connecting my softphone to the Asterisk server. Can you share more on what you meant by “Then I found the problem that I cannot register my sip softphone was because I need to set the protocol to be UDP.”? Was that a setting on your softphone or on Asterisk side? Which softphone are you using?

Also, would you be able to share the final working Asterisk configuration files in this thread?

Thank you!

Hi, Alimas:
Sorry, mine sometimes works and most time doesn’t. It has all sort’s of problems cannot register is one of them. Even it registers, sometime I can make call and then I cannot. I think Asterisk 1.8 is not stable for Debian/ARM yet. If I find any solution, I will certainly post. Hope you can do so also.

Hi twinclouds,

Thanks for your reply.

I still don’t know what the “Wrong password” problem is caused by. I looked at the code (chan_sip.c) and saw that it has the provision of an insecure way to allow me to experiment more, i.e. not specifying any password (a.k.a. “secret”). I was able to make a few test calls.

I thought the bug reported in “ast_md5_hash sometimes create incorrect md5 digest” (https://issues.asterisk.org/view.php?id=18209) might be the cause but after comparing the different revisions of the code, it doesn’t look like anything really changed with the MD5 computation since whatever revision that was released with Asterisk 1.6.2.10 that the bug filer claimed to always work correctly.

If your set-up is not consistently working, I hope there isn’t a timing/threading issue in Asterisk as that’s usually tougher to debug.

I will share more if/when I find anything new or if the insecure (no password) mechanism works consistently without glitches after further testing.

I did notice that after I built the “iksemel” package that one of the test cases (specifically, tst-ikstack) failed when I did “make check” but I don’t think that’s what’s causing the “Wrong password” issue that I’m seeing. If you can share how you worked around that issue with the TCP vs. UDP that you mentioned in an earlier post, please let me know.

Thank you.

p.s. I’m also wondering if you’ve tried Jeff Doozan’s mtd0 replacement bootloader described through plugapps.com/index.php5?title=Pl … ug_Setboot? It sounds like safe enough but the warnings about possible bricking always makes me cringe. :wink:

[quote=“ALimas”]Hi twinclouds,

Thanks for your reply.

I still don’t know what the “Wrong password” problem is caused by. I looked at the code (chan_sip.c) and saw that it has the provision of an insecure way to allow me to experiment more, i.e. not specifying any password (a.k.a. “secret”). I was able to make a few test calls.
Thanks for sharing. Do you need to change the code or just set the secret to zero length? Set to zero length does not work for me.

I thought the bug reported in “ast_md5_hash sometimes create incorrect md5 digest” (https://issues.asterisk.org/view.php?id=18209) might be the cause but after comparing the different revisions of the code, it doesn’t look like anything really changed with the MD5 computation since whatever revision that was released with Asterisk 1.6.2.10 that the bug filer claimed to always work correctly.

If your set-up is not consistently working, I hope there isn’t a timing/threading issue in Asterisk as that’s usually tougher to debug.

I will share more if/when I find anything new or if the insecure (no password) mechanism works consistently without glitches after further testing.

Please.

I did notice that after I built the “iksemel” package that one of the test cases (specifically, tst-ikstack) failed when I did “make check” but I don’t think that’s what’s causing the “Wrong password” issue that I’m seeing. If you can share how you worked around that issue with the TCP vs. UDP that you mentioned in an earlier post, please let me know.
I have the same issue. I just ignored it. For UDP, I just set it in my softphone the transport to UDP but it does not work for me some times either.
Another issue I have is that it says “rtp_engine.c:325 ast_rtp_instance_new: No RTP engine was found.” so cannot establish the call. Do you have the same problem?

Thank you.

p.s. I’m also wondering if you’ve tried Jeff Doozan’s mtd0 replacement bootloader described through plugapps.com/index.php5?title=Pl … ug_Setboot? It sounds like safe enough but the warnings about possible bricking always makes me cringe. :wink:[/quote]

I did this on all of my Dockstars and everything works very well. Never had any problem. In my opinion, the risk is small but you need to make up you mind yourself, of course.

Yes, basically specify nothing in “sip.conf”, i.e. instead of “secret=whatever”, I just specified “secret=”. Likewise on the softphone side, just leave the password field blank. If that doesn’t work, then maybe try a different softphone. I’m currently using Mac OSX, so I’ve been using “Telephone” for my softphone. I haven’t tried any Windoze softphone yet with this set-up.

I haven’t seen that warning yet, but probably because I haven’t tested extensively enough.

I’ll just defer that until really needed. If I can get the DockStar GV solution to consistently and reliably work, then chances of it needing to be rebooted should be quite rare and I can spend the additional minute or so to doubly-boot it.

ALimas:
Thanks for your reply. Now I hope you can give me some more detailed information. Below are what I want to know:

  1. Which version of Debian (squeeze or Lenny) and Kernel version you are using?
  2. Do you need to install the KernelHeaders?
  3. Which packages you installed before install asterisk? (It will be great you can give a list of packages that you are installed.)
    I might need to reinstall Asterisk 1.8 again so any help will be greatly appreciated.

Hi twinclouds,

I actually followed your comments dated “October 28, 2010 08:17PM” in forum.doozan.com/read.php?2,1826,2192, except instead of “steps 2 and 3”, I did “steps 1 and 2” (that’s what you meant in that posting :wink: ).

[quote=“twinclouds”]ALimas:
Thanks for your reply. Now I hope you can give me some more detailed information. Below are what I want to know:

  1. Which version of Debian (squeeze or Lenny) and Kernel version you are using?[/quote]
    It’s Debian Lenny. “uname -r” returns “2.6.34.1”.

Yes, I installed everything in those steps.

Other than the “iksemel” which is the prerequisite for “chan_gtalk” and “res_jabber”, I also invoked “get_mp3_source.sh” which needed “svn” (subversion) which I didn’t have, so I installed “svn”.

These are basically the commands I invoked:

A. Installing Debian - I simply copied and pasted the script from step #1 and ran the script.

B. Installing Kernel files.

debian:~# ntpdate pool.ntp.org
debian:~# dpkg-reconfigure tzdata
debian:~# dpkg-reconfigure locales
debian:~# vi /etc/hostname
debian:~# apt-get update
debian:~# apt-get dist-upgrade
debian:~# apt-get -y install make gcc g++ libxml2 libxml2-dev ssh libncurses5 libncursesw5 libncurses5-dev libncursesw5-dev linux-libc-dev sqlite libnewt-dev libusb-dev zlib1g-dev libmysqlclient15-dev libsqlite0 libsqlite0-dev bison openssl libssl-dev libeditline0 libeditline-dev libedit-dev mc sox libedit2 libedit-dev curl libcurl4-gnutls-dev apache2 libapache2-mod-php5 php-pear
debian:~# apt-get -y install php5
debian:~# apt-get -y install php5-cli
debian:~# apt-get -y install mysql-server
debian:~# apt-get -y install php5-mysql php-db libapache2-mod-php5 php5-gd php5-curl mysql-client
debian:~# apt-get -y install openssh-server build-essential openssh-client zlib1g zlib1g-dev libtiff4 libtiff4-dev libnet-telnet-perl mime-construct libipc-signal-perl libmime-types-perl libproc-waitstat-perl mpg123
debian:~# cd /usr/src
debian:/usr/src# wget http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.34.1.tar.gz
debian:/usr/src# tar -zxvf linux-2.6.34.1.tar.gz
debian:/usr/src# ls -ld /usr/src/linux*
debian:/usr/src# pushd /usr/src/
debian:/usr/src# ln -s linux-2.6.34.1 linux
debian:/usr/src# popd
debian:/usr/src# ls -ld /usr/src/linux*
debian:/usr/src# wget http://sheeva.with-linux.com/sheeva/2.6.34.1/sheeva-2.6.34.1.config
debian:/usr/src# cp sheeva-2.6.34.1.config /usr/src/linux-2.6.34.1/.config
debian:/usr/src# cd /
debian:/# wget http://sheeva.with-linux.com/sheeva/2.6.34.1/sheeva-2.6.34.1-KernelHeaders.tar.gz
debian:/# tar -zxvf sheeva-2.6.34.1-KernelHeaders.tar.gz
debian:/# cd /usr/src/linux-2.6.34.1
debian:/usr/src/linux-2.6.34.1# make menuconfig
debian:/usr/src/linux-2.6.34.1# rm /lib/modules/`uname -r`/build
debian:/usr/src/linux-2.6.34.1# rm /lib/modules/`uname -r`/source
debian:/usr/src/linux-2.6.34.1# ln -s /usr/src/linux-2.6.34.1 /lib/modules/`uname -r`/build
debian:/usr/src/linux-2.6.34.1# ln -s /usr/src/linux-2.6.34.1 /lib/modules/`uname -r`/source
debian:/usr/src/linux-2.6.34.1# make modules_prepare

C. Building Asterisk 1.8 without having installed “iksemel”.

debian:~# cd /usr/src
debian:/usr/src# wget http://downloads.asterisk.org/pub/telephony/asterisk/asterisk-1.8-current.tar.gz
debian:/usr/src# tar xvfz asterisk-1.8-current.tar.gz
debian:/usr/src# cd asterisk-1.8.0
debian:/usr/src/asterisk-1.8.0# contrib/scripts/get_mp3_source.sh
debian:/usr/src/asterisk-1.8.0# apt-get -y install svn
debian:/usr/src/asterisk-1.8.0# apt-get -y install subversion
debian:/usr/src/asterisk-1.8.0# contrib/scripts/get_mp3_source.sh
debian:/usr/src/asterisk-1.8.0# ./configure
debian:/usr/src/asterisk-1.8.0# vi makeopts
debian:/usr/src/asterisk-1.8.0# make menuconfig
debian:/usr/src/asterisk-1.8.0# make
debian:/usr/src/asterisk-1.8.0# make install

D. Installing “iksemel” and re-building Asterisk 1.8. I must have either rebooted or opened a new shell at this point as the new hostntame is now reflected in the prompt. I added a line to my /etc/hosts file to have “dockstar-debian” be another mapped name for the loopback address (127.0.0.1). I don’t recall what the warning/error message was but I did see it at some point while starting up Asterisk that that hostname was unknown.

dockstar-debian:~# cd /usr/src
dockstar-debian:/usr/src# wget http://iksemel.googlecode.com/files/iksemel-1.4.tar.gz
dockstar-debian:/usr/src# tar xvfz iksemel-1.4.tar.gz
dockstar-debian:/usr/src# cd iksemel-1.4
dockstar-debian:/usr/src/iksemel-1.4# ./configure –prefix=/usr –with-libgnutls-prefix=/usr –with-gnutls
dockstar-debian:/usr/src/iksemel-1.4# make
dockstar-debian:/usr/src/iksemel-1.4# make check
dockstar-debian:/usr/src/iksemel-1.4# make install
dockstar-debian:/usr/src/iksemel-1.4# cd ../asterisk-1.8.0/
dockstar-debian:/usr/src/asterisk-1.8.0# ./configure
dockstar-debian:/usr/src/asterisk-1.8.0# make menuselect
dockstar-debian:/usr/src/asterisk-1.8.0# make
dockstar-debian:/usr/src/asterisk-1.8.0# make install

Just let me know if you need more info. I probably won’t have time to do further testing until later during the week but can try to respond of what I had done so far.

Thanks. I will try to do another install as you did.
Two questions:

  1. Do you need to do a sed -i ‘s/PROC=@HOST_CPU@/PROC=arm/g’ /usr/src/asterisk-1.8.0/makeopts.in? I found it always give me an processor unknown error if I didn’t.
  2. At the end, I usually do a make config. Then I can start/stop Asterisk using /etc/init.d/asterisk (re)start or stop. If you don’t how you start, stop asterisk when you need?

Hi twinclouds,

I didn’t do any “sed”. In the step where you saw me doing a “vi makeopts”, I just changed that one line to make sure it’s “ARM”.

So far, I’ve just been starting it up manually being still in debugging state, so I have just been invoking “/usr/sbin/asterisk -c -vvvvvv” (don’t remember how many "v"s I’ve been using, definitely more than just one just to be as verbose).

Thanks for your reply. I understand your both points. I used asterisk -cvvvvv to start it as well but after that, I don’t know how to stop it if I need to. Maybe you don’t need to stop because it is in debug mode anyway.
I will keep posting my progress (or lack of :wink: ).

[quote=“twinclouds”]Thanks for your reply. I understand your both points. I used asterisk -cvvvvv to start it as well but after that, I don’t know how to stop it if I need to. Maybe you don’t need to stop because it is in debug mode anyway.
I will keep posting my progress (or lack of :wink: ).[/quote]
Hi twinclouds,

You’re welcome.

From within the Asterisk CLI (that you get from the “-c” flag), you simply do a “core stop now” to gracefully stop the server.

Hi, ALimas:
I can login now has no problem. However, I always got:
ERROR[23208]: rtp_engine.c:325 ast_rtp_instance_new: No RTP engine was found. Do you have one loaded?
[Nov 9 13:06:32] ERROR[23208]: chan_sip.c
:8078 process_sdp: Got SDP but have no RTP session allocated.
Do you have any idea I can look for the cause? Thanks.
BTW, Do you select mysql module? I didn’t.

Hi twinclouds,

[quote=“twinclouds”]However, I always got:
ERROR[23208]: rtp_engine.c:325 ast_rtp_instance_new: No RTP engine was found. Do you have one loaded?
[Nov 9 13:06:32] ERROR[23208]: chan_sip.c
:8078 process_sdp: Got SDP but have no RTP session allocated.
Do you have any idea I can look for the cause? Thanks.[/quote]
I’ve not seen that and just did a (case-insensitive) grep of all files under /var/log/ and don’t see any occurences of “rtp” or “sdp”.

The “mysql” package for Debian is installed and “app_mysql” is selected under Asterisk “Add-ons”.

Spoke too soon. I haven’t turned on my DockStar for more than a day. Back then I was able to get the SIP connection established properly and made a few test calls where I got properly connected on all test calls. Today, I’m seeing the same RTP issue whenever trying to register the SIP phone, i.e. “ERROR[2459] rtp_engine.c: No RTP engine was found. Do you have one loaded?” followed by “ERROR[2459] chan_sip.c
: Got SDP but have no RTP session allocated.”

I found dev.openwrt.org/ticket/8132 but didn’t have time to look at it closely to see if the patch would work (especially since it was working just less than 2 days ago and nothing changed/got reconfigured).

I am in the same boat. I installed it first time and it works. Then, it stopped working with nothing changed. I am not familiar Asterisk even linux programming, looks like you have more experience than me. Please let me know if you find anything out can fix the problem. I will try but not confident.
I read from googling that it need a package asterisk18-res-rtp-asterisk. I checked the package res-rtp-asterisk was selected but don’t know if it is the samething. Let’s hope we will be able to find a solution soon.

Do you guys have this problem on regular x86 systems?

I am installed PIAF on a X86 box (viewtopic.php?f=1&t=75918). It seems this problem also occurred and got fixed. However, I don’t know what system was used and am still waiting for the details how the problem got fixed.
The strange thing about the problem that we are having is that it worked once then stopped working, even though nothing has been changed.
It’s a shame that we cannot get it work on Dockstar. It works so well on the X86 box I even cannot tell it is not a regular (circuit switched) telephone.