Git-master not doing outbound, 18-rc1 does

When dialing out I get a ‘three-tone’. CLI shows: Everyone is busy/congested at this time (1:0/0/1)
Auto fallthrough, channel ‘PJSIP/1002-000000000’ status is ‘CHANUNAVAIL’
The ‘000000…’ seems wrong?
Inbound works fine.
Asterisk 17.x and 18-rc1 work fine both ways.
Same *.conf for all.
Git-master worked several weeks ago but I don’t have exact date.

That’s not really enough information, and the 000000 is fine. What is being dialed? Did the configuration load for it or present an error? Is the contact reachable? Are you using chan_sip for outbound?

Cisco ata
Error 21681: ari/config.c:312 process_config: No config users for ari
Warn 21684: chan_sip.c depricated (I compiled with it to see if that was related but I’m not using)
pjsip show registrations=registered (4 accounts)
Extension to extension dialing works
Inbound works

That’s still not enough information. You’ll need to provide the complete console output, as well as the output of “pjsip show contacts”, and configuration information for the endpoint in question.

pjsip show contacts:
Contact: 1001/sip"1001@192.168.1.2:5061 21a… NonQual nan
Contact: 1002/sip"1002@192.168.1.2:5060;transport=UDP a3… NonQual nan
Contact: 1003/sip"1003@192.168.1.2:5062 7bg… NonQual nan
Contact: 1004/sip"1004@192.168.1.2:5060 581… NonQual nan
and sip url’s for each below this

After dialing, in CLI:
Setting global variable ‘SIPDOMAIN’ to 192.168.1.5
Executing [2135554444@Outbound-1002:1] Dial(“PJSIP/1002-00000000”, “PJSIP/12135554444@oursip1002,r”) in new stack
Called PJSIP/12135554444@oursip1002
Everyone is busy/congested at this time (1:0/0/1)
Auto fallthrough, channel ‘PJSIP/1002-00000000’ status is ‘CHANUNAVAIL’

Okay, so does “oursip1002” appear in “pjsip show endpoints”? What is its configuration?

My post shows comma r but I typed comma comma r

Yes, and this all works with Asterisk 17 and 18-rc1:
[oursip1002]
type=transport
protocol=flow

[oursip1002]
type=registration
outbound_auth=oursip1002
server_uri=sip: the url here
outbound_proxy=sip: different url2 here:5061;transport=tls;lr;hide
client_uri=sip:2135554444@ the url here
retry_interval=60
support_path=yes
support_outbound=yes
line=yes
endpoint=oursip1002
contact_header_params=obn=3456756
endpoint=oursip1002
transport=oursip1002
forbidden_retry_interval=60

[oursip1002]
type=auth
auth_type=google_oauth
refresh_token=3579e8rutiuefgoireFAKE
oauth_clientid=tyt456456yFAKE
oauth_secret=uyiohj546rger6FAKE
username=2135554444
realm= the url here

[oursip1002]
type=aor
contact=sip: the url here

[oursip1002]
type=endpoint
context=Inbound-1002
disallow=all
allow=ulaw
outbound_auth=oursip1002
outbound_proxy=sip: url2;transport=tls;lr;hide
aors=oursip1002
direct_media=no
ice_support=yes
rtcp_mux=yes
media_use_received_transport=yes
transport=oursip1002

[1002]
type=aor
max_contacts=3

[auth1002]
type=auth
auth_type=userpass
password= password in ata
username=1002

[1002]
type=endpoint
context=Outbound-1002
disallow=all
allow=ulaw
auth=auth1002
aors=1002

I’m sorry, I am not supporting Google Voice.