G729 packetization

We have an Asterisk server 1.8.11 that is set for “allow=g729:60” but calls coming in to the server requesting bytes 60 have the re-invite changed to bytes 20.
The termination end is also requesting bytes 60, and the autoframing is also turned on.
Why is the server defaulting to bytes 20 when everything tells it to use 60?

It very well may be a bug. Before doing any reporting, make sure you’ve tried to replicate on the latest supported version of your branch, and read the guidelines:

wiki.asterisk.org/wiki/display/ … Guidelines

I work with the OP and have details on the environment.

The production environment we are running is:
Asterisk 1.8.11-cert1
CentOS release 6.5 (Final) x64

I’ve also reproduced the same problem in the lab with Asterisk 11.7.0. I downloaded the asterisk-11-current.tar.gz and installed fresh today.

I’ve also tried setting up specific dialpeers for the destination and only allowing g729:60, but it does not change anything.

Sip.conf:
pastebin.com/39WhSh15

Tcp dump Sip trace:
pastebin.com/n70RMpiC

I’ve opened issue 23251:
issues.asterisk.org/jira/browse/ASTERISK-23251