Functioning PSTN line with Red alarm?

This is my first time installing a PBX…

I am running FreePBX (Distro) 6.12.65-32 with Asterisk 11.21.2 with an analogue card installed with 3 FXO ports (digium). On FreePBX the card is recognised and configurable. I have setup a trunk, outgoing and ingoing route.

I have connected a functioning PSTN line to port 1, but every time i ring out, it does not connect as users busy" I have plugged the PSTN line to the other 3 ports with the same problem. When i go into DAHDI config there is a red alarm against each channel… (with the PSTN line plugged in)?

I am sure the PSTN line is functional, so I assume this is something to do with my config?

The red alarm on a analog port typically means the card cannot detect the proper voltage level for the line. Does the line have something close the the 48V of battery on it?

You should be able to use fxstest stats to read what the voltage levels are currently.

1 Like


Ive tried this but cannot get the command to work for some reason?

when i try service dahdi status:

all this FXO ports are recognised but each one has " (In Use) (EC: MG2 - Inactive) RED

Despite a line being connect to FXO line 1?

Here is the output of when I run the command on an FXO port, first with the cable connected, and then disconnected:

[root@charlie dahdi-tools]# ./fxstest /dev/dahdi/23 stats
TIP: -44.0000 Volts
RING: -44.0000 Volts
VBAT: -44.0000 Volts
[root@charlie dahdi-tools]# ./fxstest /dev/dahdi/23 stats
TIP:  1.0000 Volts
RING:  1.0000 Volts
VBAT:  1.0000 Volts

fxstest is built in dahdi-tools when

Thanks you for you continued help! I’m really sorry but this is my first time and on a steep learning curve. I am able to enter the dahdi_tool via the asterisk CLI, but cannot get to the FXSTEST. are you able to explain the command i need to run.

Thanks again!