FreePBX 2.11 problem placing calls on hold

We have FreePBX 2.11 with Asterisk 11.4.
Our phones are Snom-320.

The System is awesome and works great, has many great features. There is always that one problem that we can live with, but would rather get it solved. In our case, it is placing calls on-hold.

If I receive or place a call and push “hold” on the phone, the light blinks and I hear a new dial tone, which is what you would expect. Now, if I to hangup the receiver, one would expect that the call will remain on hold, light blinking indicating that, and I can pick up the the receiver later and poke a button and continue the conversation. Unfortunately in our case it is not the case. If I answer or place a call, then push “hold” everything is fine, but as soon as I hangup the receiver, the speaker phone gets activated with the dial tone audible. I tried to push any button that I would think can stop this to no avail. The only thing that I can do, it to call somewhere else. So the phone-set basically insists on me dialing another number or pickup the call from “hold”. Having just a quiet time is not an option.

If anyone knows what this is about and how to fix it, please let me know. I have tried old and less clever Snom-190, and it also exhibits the same behavior.

Please help. Thank you,

  1. This board knows very little about FreePBX.

  2. Unless you are using dahdi, this issue will be with the phone. If you are using dahdi, what do you mean by pressing the hold button, as phones will have a register recall button, not a hold button.