Forwarding problem

Hi All,

We are currently using FreePBX and having some issues with call forwarding;
Your Linux Distribution: (Debian 7.11)
Your FreePBX version: (13.0.192.19)

I’m unable to forward to any outside phone number. It works only with inside numbers.
This is a part from asterisk log:
[2017-10-12 18:06:35] VERBOSE[7874][C-0000017f] pbx.c: Executing [s@macro-dialout-trunk:23] Dial(“Local/90885492022@from-internal-00000042;2”, “SIP/MtelVoice/0885492022,300,”) in new stack
[2017-10-12 18:06:35] VERBOSE[7874][C-0000017f] netsock2.c: Using SIP RTP TOS bits 184
[2017-10-12 18:06:35] VERBOSE[7874][C-0000017f] netsock2.c: Using SIP RTP CoS mark 5
[2017-10-12 18:06:35] VERBOSE[7874][C-0000017f] app_dial.c: Called SIP/MtelVoice/0885492022
[2017-10-12 18:06:35] WARNING[25510][C-0000017f] chan_sip.c: Received response: “Forbidden” from “;tag=as63d2cec5”
[2017-10-12 18:06:35] WARNING[25510][C-0000017f] chan_sip.c: Received response: “Forbidden” from “;tag=as63d2cec5”
[2017-10-12 18:06:35] VERBOSE[7874][C-0000017f] app_dial.c: Everyone is busy/congested at this time (1:0/0/1)
[2017-10-12 18:06:35] VERBOSE[7874][C-0000017f] pbx.c: Executing [s@macro-dialout-trunk:24] NoOp(“Local/90885492022@from-internal-00000042;2”, “Dial failed for some reason with DIALSTATUS = CHANUNAVAIL and HANGUPCAUSE = 21”) in new stack

I already contact my sip provider (MtelVoice) but the told me that I have to use “diversion headers” and the problem is in my PBX.
“Generate Diversion Headers” is set to “no” in my advanced settings . I try to switch from “no” to “yes” but nothing change …
A month ago I had the same “Follow me” and “Ring Groups” rules and everything was fine, suddenly I spot this issue.

I’ll appreciate any ideas.

Best!

as you already know the carrier ir is rejecting your invite request to the fowarded number, as you are using freepbx I suggest you follow this topic https://community.freepbx.org/t/adding-a-custom-diversion-header/23959/6

1 Like