"Forbidden" from .......message

Since I installed a new Asterisk 1.4.11 + Debian 4.0, I can’t connect to sip provider VYKE . :unamused:
(vyke.com)

My configuration is like this:

sip.conf

;register to Vyke
register => henkoegema:xxxxxx@sip.vyke.com

[vyke-out]
type=peer
username=henkoegema
secret=xxxxxx
host=sip.vyke.com
fromuser=henkoegema
context=default
canreinvite=no
insecure=very
qualify=yes
nat=yes
port=5060
dtmfmode=rfc2833
disallow=all
allow=ulaw
allow=alaw

I copied and pasted this from my earlier working configuration :smiley:

Registration is OK:
[vyke-out/henkoegema 66.205.178.59 N 5060 OK (135 ms)

When setting up a connection, I get:

  • Called vyke-out/003216980102
    [Sep 19 07:10:23] WARNING[7933]: chan_sip.c:12016 handle_response_invite: Received response: “Forbidden” from ‘“Henk” sip:henkoegema@84.197.82.228;tag=as4ba53b99’
    – SIP/vyke-out-08239d70 is circuit-busy

    == Everyone is busy/congested at this time (1:0/1/0)
    – Executing [016980102@default:2] Congestion(“SIP/1200-08235e00”, “”) in new stack
    == Spawn extension (default, 016980102, 2) exited non-zero on ‘SIP/1200-08235e00’

When I contacted Vyke support they answered as follows::

Please do enter the hostname instead of the IP address to avoid the error message to be prompt.
For eg. "henkoegema@sip.vyke.com

I don’t know how to handle this answer :cry:

What they want you to do is what you are already doing which is using the host name and not an IP (they want host=sip.vyke.com and NOT host=66.205.178.59). What version of asterisk did it work on and which one did it not work on ?

It worked perfectly well in Asterisk 1.2.x :laughing: and also in a lower version than the one which I’m using now (1.4.11) :frowning:

It worked perfectly well in Asterisk 1.2.x :laughing: and also in a lower version than the one which I’m using now (1.4.11) :frowning:[/quote]

I had someone tested it in Asterisk version 1.4.7 and it did NOT work there either.

With softphone SJPhone and ZoIPer it works fine. Both SIP and IAX. :smiley:

Then it should work also with Asterisk. Isn’t it. :unamused:

[quote=“henkoegema”][quote=“henkoegema”][quote=“Dovid”]

With softphone SJPhone and ZoIPer it works fine. Both SIP and IAX. :smiley:

Then it should work also with Asterisk. Isn’t it. :unamused:[/quote][/quote][/quote]

These are the settings as described on their website:

Settings for Vyke SIP:
Display name: henkoegema
SIP/IAX Username: henkoegema
SIP/IAX Password: ***** (Same as your vyke password if confirmed)
SIP server: sip.vyke.com
IAX Server: iax.vyke.com
Port: 5060
RTP port: 5090
DTMF: RFC 2833
Proxy settings: Same as SIP server
Register server: Leave blank
Supported codecs: G.729, G.711 (ulaw), gsm

These are MY setings:

sip.conf

;register to Vyke
register => henkoegema:xxxxxx@sip.vyke.com

[vyke-out]
type=peer
username=henkoegema
secret=xxxxxx
host=sip.vyke.com
fromuser=henkoegema
context=default
canreinvite=no
insecure=very
qualify=yes
nat=yes
port=5060
dtmfmode=rfc2833
disallow=all
allow=ulaw
allow=alaw

Can somebody see a mistake in my settings? :angry:

After struggling for more than a week, I still haven’t been able to solve the connection problem with vyke.com :frowning:

I have tested the connection with another Asterisk version (1.2.24) (i.s.o. 1.4.11) and get:

…WARNING(6140): handle_response_invite: Forbidden-wrong password on authentication for INVITE…
(this is at least a [size=59]small [/size]step forward :smile: )

In Asterisk 1.4.11 I also got Forbidden… .but not the text: wrong password on authentication

I’m still trying to find out what is wrong with the password.
When I use a softphone, with the same password which I use in Asterisk, it connects.

[vyke-out]
type=peer
username=henkoegema
secret=xxxxxx
host=sip.vyke.com
fromuser=henkoegema
fromdomain=sip.vyke.com <----------This was the solution :smiley: !!
context=default
canreinvite=no
insecure=very
qualify=yes
nat=yes
port=5060
dtmfmode=rfc2833
disallow=all
allow=ulaw
allow=alaw