[FIXED!] T400P and X100p


#1

Setup:
I was using the x100p as an outbound local with all SIP phones on the inside. Everything was working great. I installed a T400P and that went fine. Now when I pick up a sip phone and dial an outside local # it just goes to dead air … nothing… then a fast busy signal. the x100p is channel one and and all calls should go to g0 but they seem to try to hit the T400P first…

Please help


#2

I think it depends wich card you load first as to wich would be channel 1

If you loaded the x100p first it would be channel 1 then the 400 would be 2,3,4,5


#3

that is what it is doing. First the x100p loads then the tor2 loads.


#4

OK, maybe I jumped the gun a bit…

How do I see what the module loading order is?


#5

The call says it is going out ‘Zap/1/1’

A) What does that mean?
B) How do I know that is the X100P
C) How do I change it if its not?

I know I’m asking a lot but any and all help would be appreciated.


#6

Can anyone help with this, The log makes it look like it is trying to complete the call but it never does, just dead air, then when I hang-up the log indicates that but still no error.

Also as a side note, incoming calls on the X100P nolonger work either.


#7

Sorry for taking so long to reply

I think the order depends on wich card you modprobe first but have read that others have had to change the order to get 2 cards in 1 box to work


#8

There is two way you can fix this. But first you need to know which driver is load first. If you did’nt load the driver manually in a script then your kernel probably does it by itself. So to find out wich ones load first, do the command dmesg. It will list all your console message and you’ll find out wich one load first.

So from that point you can find a way the change the order of loading driver, but if your kernel does it by itself, it could be easier to change your config in zapata.conf to reflect the group you want to use.

Exemple of zapata.conf
signaling=fxs_ks
context=incoming
group=1
channel => 1
group=2
channel => 2-5

Hope this help !


#9

That fixed it. By changing the order of the driver loading etherthing now is back to working the way it was.

Thanks Again Everyone!