Fedora Core 4 with RAID/SATA/ATA Driver Support


Does anyone know where I can download a more recent copy of Fedora Core 4 with RAID and SATA driver support. Ever since I got a new machine I have not being able to install FC4 which is more compatible with * than FC5 which I currently use (see asteriskvoipnews.com/asteris … ore_5.html) . And since I started using FC5 remote extensions have not been able to register with * not even once even though I see SIP 5060 incoming on my router logss. But with FC4 I never had that problem.

Or if anyone has anyway for me to go about this remote extension issue on FC5 please let me know. And if anyone can recommend any Suse Linux versions that are RAID/SATA and * compatible and obviously won’t have any problems as I currently have with FC5.


User Fedora Core 6, we have internally tested it and it works just fine, our production systems use FC-4 but we are scheduling an update of all our servers in the very near future. You will also find that FC-6 supports SATA drives great as well, we use Western Digital Raptor drives in our systems and it was just a plug in, and install and away we went.

FC-5 has too many problems with it, and FC-4 just got old and lacked many driver supports and functionality.



Thanx for the response. I have just tried a fully updated FC6 with * 1.4 and remote extensions still cannot register even though my ISP says those port ranges are all open and I see port 5060 incoming on my router. I have also changed routers to troubleshoot, didn’t help. Do you have any suggestions? This was not an issue on FC4. On your FC6 trial, how did you go about remote extension registration and what configuration do you have?

FYI; Using FC6 has just added a new problem; during a call to Dell to see if they have linux SATA HDD drivers, on the IVR I pushed the numbers appropriate for my call, as I did it does not transmit the dialed numbers to the Dell phone system. So I even pushed all the numbers on the phone without response. Than I called Microsoft just to test, the same thing, then I called my ISP to further test; same thing happened; the digits dialed during a call does not make it to the other side. This was not an issue on previous Fedora versions. So don’t be so quick to move unto new distros. I still need my original issues resolved.

No offense but these seem more like config issues than distro-related issues.

For your ports issue, they are probably being blocked by the Fedora built in firewall. You can kill it with:
service iptables stop
but keep in mind that kills your entire firewall. If you want to configure it to work right google for info on setting up iptables.

As for your DTMF issue (pushing numbers) that is probably because in moving to the new OS you didn’t correctly set up the dtmfmode= on the SIP channels. What distro you use will not affect this.

Thanx for the response. My firewalls are always installed as disabled as on FC4 that worked fine so I don’t think its a firewall issue. This is manily so things can work fine and my router firewall is good enough. Now registration is happening but no audio in either direction even though i have ports 5000 - 31000 forwarded to *. The error shows:

– Executing [1001@internal-ext:1] Dial(“SIP/1234-08ae9bd0”, “SIP/1001|30”) in new stack
– Called 1001
– SIP/1001-08ae4300 is ringing
– SIP/1001-08ae4300 answered SIP/1234-08ae9bd0
– Packet2Packet bridging SIP/1234-08ae9bd0 and SIP/1001-08ae4300
== Spawn extension (internal-ext, 1001, 1) exited non-zero on ‘SIP/1234-08ae9bd0’
[Feb 26 11:12:28] WARNING[30234]: chan_sip.c:1881 retrans_pkt: Maximum retries exceeded on transmission Y2M0OGI4ZGFiMjA0MzdiYjE5ZjZkOTdiZmVmM2RlODk. for seqno 2 (Critical Response)
[Feb 26 11:12:37] WARNING[30234]: chan_sip.c:1881 retrans_pkt: Maximum retries exceeded on transmission Y2M0OGI4ZGFiMjA0MzdiYjE5ZjZkOTdiZmVmM2RlODk. for seqno 2 (Critical Response)

you may have NAT issues. in sip.conf set externip= (your external IP) and localnet=. Also set nat=yes. and for the side on the other end, if its behind a different NAT make sure it has STUN enabled…

Thanx for your response. I have always had all the settings set as you suggested since when it worked perfectly on FC4 and all I do is copy the same files from my flash drive into a new * install. But I don’t know about STUN enablement on the other side as that did not affect it on FC4. I will ask the other end.