FAXOPT(maxrate) not relevant


#1

I seem to have quite a problem with Free Fax for Asterisk. Specifically, its not respecting the maxrate setting in FAXOPT.

Asterisk Version: 1.8.5.0
Fax type: Digium FAX Driver: 1.8.4_1.3.0 (optimized for prescott_32)

Extensions.conf:
exten => receive,n,Set(FAXOPT(maxrate)=9600)
exten => receive,n,Set(FAXOPT(minrate)=2400)

res_fax.conf:
[general]
maxrate=9600
minrate=2400
statusevents=yes
modems=v17,v27,v29
ecm=no

The full log shows:
VERBOSE[26400] pbx.c: – Executing [h@fax-rx:1] NoOp(“DAHDI/i1/212XXXXXXX-1ec”, “FAXOPT(ecm) : no”) in new stack
VERBOSE[26400] pbx.c: – Executing [h@fax-rx:2] NoOp(“DAHDI/i1/212XXXXXXX-1ec”, “FAXOPT(filename) : /var/spool/asterisk/fax/20110801-150535-212XXXXXXX.tif”) in new stack
VERBOSE[26400] pbx.c: – Executing [h@fax-rx:3] NoOp(“DAHDI/i1/212XXXXXXX-1ec”, "FAXOPT(headerinfo) : ") in new st
VERBOSE[26400] pbx.c: – Executing [h@fax-rx:4] NoOp(“DAHDI/i1/212XXXXXXX-1ec”, "FAXOPT(localstationid) : VERBOSE[26400] pbx.c: – Executing [h@fax-rx:5] NoOp(“DAHDI/i1/212XXXXXXX-1ec”, “FAXOPT(maxrate) : 9600”) in new VERBOSE[26400] pbx.c: – Executing [h@fax-rx:6] NoOp(“DAHDI/i1/212XXXXXXX-1ec”, “FAXOPT(minrate) : 2400”) in new VERBOSE[26400] pbx.c: – Executing [h@fax-rx:7] NoOp(“DAHDI/i1/212XXXXXXX-1ec”, “FAXOPT(pages) : 3”) in new stack
VERBOSE[26400] pbx.c: – Executing [h@fax-rx:8] NoOp(“DAHDI/i1/212XXXXXXX-1ec”, “FAXOPT(rate) : 14400”) in new stack


#2

Hi there,

I’m experiencing the same problem where my asterisk log shows;

-- Executing [s@inboundfax:7] Set("SIP/flowroute-00000199", "FAXOPT(maxrate)=9600") in new stack
-- Executing [s@inboundfax:8] Set("SIP/flowroute-00000199", "FAXOPT(minrate)=2400") in new stack

-- Executing [s@inboundfax:12] NoOp("SIP/flowroute-00000199", "FAXOPT(maxrate) : 9600") in new stack
-- Executing [s@inboundfax:13] NoOp("SIP/flowroute-00000199", "FAXOPT(minrate) : 2400") in new stack

those last 2 lines are:
exten => s,n,NoOp(FAXOPT(maxrate) : ${FAXOPT(maxrate)})
exten => s,n,NoOp(FAXOPT(minrate) : ${FAXOPT(minrate)})

So I know that at this point, the FAXOPT(maxrate) and FAXOPT(minrate) have been set. However after the fax is processed, ${FAXOPT(rate)} = 14400.

Am I misunderstanding the functionality of ${FAXOPT(maxrate)} or is this a problem? If so, does anyone have any ideas as to how to force the maxrate to be 9600?

Here is what my res_fax.conf looks like;

[general]
; Maximum Transmission Rate
; Possible values are { 2400 | 4800 | 7200 | 9600 | 12000 | 14400 }
; Set this value to the maximum desired transfer rate. Default: 14400
maxrate=9600

; Minimum Transmission Rate
; Possible values are { 2400 | 4800 | 7200 | 9600 | 12000 | 14400 }
; Set this value to the minimum desired transfer rate. Default: 2400
minrate=2400

; Send Progress/Status events to manager session
; Manager events with ‘call’ class permissions will receive events indicating the
; steps to initiate a fax session. Fax completion events are always sent to manager
; sessions with ‘call’ class permissions, regardless of the value of this option.
; Default: no
statusevents=yes

; modem capabilities
; Possible values are { v17 | v27 | v29 }
; Set this value to modify the default modem options. Default: v17,v27,v29
modems=v17,v27,v29

; Enable/disable T.30 ECM (error correction mode) by default.
; Default: Enabled
ecm=yes

So the default is already at 9600… Im very confused!


#3

The problem is easy to understand if you realize that FAXOPT(maxrate) isn’t working properly.

Which version of Asterisk are you using. Mine is 1.8.5.0.


#4

1.8.4.4 here. If FAXOPT(maxrate) isnt working, is there any way to force an incoming fax to transfer at a lower rate? Getting lots of negotiation problems when the transfer rate is so high (14400).


#5

Agreed I get lots of errors to, which is why I switched back to using a real fax machine (connected to a channel bank) until this is solved. Maybe now that I’m not the only one with the error, someone will do something about it.


#6

Unfortunately, I wouldn’t get my hope up too high.

viewtopic.php?t=73048

It seems this has been a problem for a while now, but since faxing is a dieing breed , I suppose it isn’t as important to address.