Fax troubles on

I’ve just installed fax support for my asterisk. All was done according to this manual. Now I can recieve faxes, but unable to send.

My asterisk works together with Samsung PBX using sip.

Each time I try to send fax, I get

I didn’t find the solution in Internet… What can be done with this?

I can post all the information (configs, debug) you ask.

The PBX hasn’t told you what address and port number to transmit the fax data to. You can’t send a fax if you don’t know where to send it!

I’d suggest using sip set debug to get the actual SDP, and if it has been parsed correctly, use it as evidence when you take up the problem with Samsung.

Thank you! 8)

I have one more question.

My config:

exten => send,1,NoOp(**** SENDING FAX ****)
exten => send,n,Wait(6)
exten => send,n,Set(GLOBAL(FAXCOUNT)=$[ ${GLOBAL(FAXCOUNT)} + 1 ])
exten => send,n,Set(FAXCOUNT=${GLOBAL(FAXCOUNT)})
exten => send,n,Set(FAXFILE=faxout.tif)
exten => send,n,NoOp(**** SETTING FAXOPT ****)
exten => send,n,Set(FAXOPT(filename)=${FAXFILE})
exten => send,n,Set(FAXOPT(ecm)=yes)
exten => send,n,Set(FAXOPT(headerinfo)=Fax from ${GLOBAL(LASTFAXCALLERNAME)} at ${GLOBAL(LASTFAXCALLERNUM)} was received.)
exten => send,n,Set(FAXOPT(localstationid)=1234567890)
exten => send,n,Set(FAXOPT(maxrate)=14400)
exten => send,n,Set(FAXOPT(minrate)=2400)
exten => send,n,NoOp(**** SENDING FAX : ${FAXFILE} ****)
exten => send,n,SendFAX(/home/fax/faxout/${FAXFILE},d)

I don’t get where I should enter the number of the fax-machine where the fax must be sent… Can anyone explain it, please?

through an originate command… you call the number and when answer redirect to fax-tx,send,1

can you “ReceiveFax”? can i ask your sip and extensions conf?

So I call 555-9999, then I redirect it to send?
Can you show the example?

of course!
It is a beta config, but I cat receive faxes from fax-machine connected to the Samsung PBX.


exten => 7975,1,Goto(fax,receive,1)
exten => receive,1,NoOp(**** FAX RECEIVE ****)
exten => receive,n,Set(GLOBAL(FAXCOUNT)=$[1 + ${GLOBAL(FAXCOUNT)}])
exten => receive,n,Set(FAXCOUNT=${GLOBAL(FAXCOUNT)})
exten => receive,n,Set(FAXFILE=fax-${FAXCOUNT}-rx.tif)
exten => receive,n,Set(GLOBAL(LASTFAXCALLERNUM)=${CALLERID(num)})
exten => receive,n,Set(GLOBAL(LASTFAXCALLERNAME)=${CALLERID(name)})
exten => receive,n,NoOp(**** SETTING FAXOPT ****)
exten => receive,n,Set(FAXOPT(filename)=${FAXFILE})
exten => receive,n,Set(FAXOPT(ecm)=yes)
exten => receive,n,Set(FAXOPT(headerinfo)=MY FAXBACK RX)
exten => receive,n,Set(FAXOPT(localstationid)=1234567890)
exten => receive,n,Set(FAXOPT(maxrate)=14400)
exten => receive,n,Set(FAXOPT(minrate)=2400)
exten => receive,n,NoOp(FAXOPT(ecm) : ${FAXOPT(ecm)})
exten => receive,n,NoOp(FAXOPT(headerinfo) : ${FAXOPT(headerinfo)})
exten => receive,n,NoOp(FAXOPT(localstationid) : ${FAXOPT(localstationid)})
exten => receive,n,NoOp(FAXOPT(maxrate) : ${FAXOPT(maxrate)})
exten => receive,n,NoOp(FAXOPT(minrate) : ${FAXOPT(minrate)})
exten => receive,n,NoOp(**** RECEIVING FAX : ${FAXFILE} ****)
exten => receive,n,ReceiveFAX(/var/spool/asterisk/fax/${FAXFILE},cd)
exten => receive,n,system(tiff2pdf -o /var/spool/asterisk/fax/fax-${GLOBAL(FAXCOUNT)}.pdf /var/spool/asterisk/fax/${FAXFILE} && rm /var/spool/asterisk/fax/${FAXFILE})
exten => h,1,NoOp(FAXOPT(ecm) : ${FAXOPT(ecm)})
exten => h,n,NoOp(FAXOPT(filename) : ${FAXOPT(filename)})
exten => h,n,NoOp(FAXOPT(headerinfo) : ${FAXOPT(headerinfo)})
exten => h,n,NoOp(FAXOPT(localstationid) : ${FAXOPT(localstationid)})
exten => h,n,NoOp(FAXOPT(maxrate) : ${FAXOPT(maxrate)})
exten => h,n,NoOp(FAXOPT(minrate) : ${FAXOPT(minrate)})
exten => h,n,NoOp(FAXOPT(pages) : ${FAXOPT(pages)})
exten => h,n,NoOp(FAXOPT(rate) : ${FAXOPT(rate)})
exten => h,n,NoOp(FAXOPT(remotestationid) : ${FAXOPT(remotestationid)})
exten => h,n,NoOp(FAXOPT(resolution) : ${FAXOPT(resolution)})
exten => h,n,NoOp(FAXOPT(status) : ${FAXOPT(status)})
exten => h,n,NoOp(FAXOPT(statusstr) : ${FAXOPT(statusstr)})
exten => h,n,NoOp(FAXOPT(error) : ${FAXOPT(error)})

in sip.conf I’ve uncommented only this option

t38pt_udptl = yes

for example through asterisk cli


originate <destination tech/number> extension send@fax-tx

through a sip trunk?

can you give me the sip configuration?
or the output of “sip show peer ” command?

Thank you

[quote=“nmazzon”]for example through asterisk cli


originate <destination tech/number> extension send@fax-tx

But how it can be done on the IP phone?
Users don’t have CLI…

through a sip trunk?

can you give me the sip configuration?
or the output of "sip show peer " command?

Thank you[/quote]

>sip show peer ATC

  * Name       : ATC
  Secret       : <Not set>
  MD5Secret    : <Not set>
  Context      : in_ATC
  Subscr.Cont. : <Not set>
  Language     : ru
  AMA flags    : Unknown
  Transfer mode: open
  CallingPres  : Presentation Allowed, Not Screened
  Callgroup    : 
  Pickupgroup  : 
  Mailbox      : 
  VM Extension : asterisk
  LastMsgsSent : 32767/65535
  Call limit   : 0
  Dynamic      : No
  Callerid     : "" <>
  MaxCallBR    : 384 kbps
  Expire       : -1
  Insecure     : port,invite
  Nat          : RFC3581
  ACL          : No
  T38 pt UDPTL : Yes
  CanReinvite  : No
  PromiscRedir : No
  User=Phone   : No
  Video Support: No
  Text Support : No
  Trust RPID   : No
  Send RPID    : No
  Subscriptions: Yes
  Overlap dial : Yes
  DTMFmode     : rfc2833
  Timer T1     : 500
  Timer B      : 32000
  ToHost       :
  Addr->IP     : Port 5060
  Defaddr->IP  : Port 0
  Transport    : UDP
  Def. Username: 
  SIP Options  : 100rel replaces replace 
  Codecs       : 0x8 (alaw)
  Codec Order  : (alaw:20)
  Auto-Framing :  No 
  100 on REG   : No
  Status       : OK (99 ms)
  Useragent    : 
  Reg. Contact : 
  Qualify Freq : 60000 ms
  Sess-Timers  : Accept
  Sess-Refresh : uas
  Sess-Expires : 1800 secs
  Min-Sess     : 90 secs

you build a script through asterisk manager and set the originate.



Can it be done such way?

User dials a number, for example 999, the prompt sais “dial the number of the fax-machine”. User dials it (ex: 555-1234), the fax is sent using this number.