Fax passthru Asterisk


I have the following setup:

[fax] -> [FXS Gateway] -> Asterisk (Sip) -> PSTN

FXS Gateway = Grandstream GXW 4004
Asterisk = 1.4.4 (AsteriskNOW beta5)

For some reason, when I call the fax machine (whether it is from a SIP phone or from the PSTN) I get the first beep of the handshake and then silence. It is almost like asterisk detected there is a fax and decided to do something else with it.

Does anyone know why this is happening and how to stop Asterisk from doing this. I have tried this on a few other Asterisk platforms:

1.2.18 - works fine
1.2.18 (different server) - no audio after first beep. This used to be 1.2.12 (I think) which worked, then I upgraded to 1.2.18 and it started breaking.

Any help appreciated!


Once again, ask a question and the answer becomes obvious :smile:

So, if anyone else has this issue, say no to the following questions in the Grandstream configuration for your profile:

DTMF in audio:
DTMF via RFC2833:

Managed to get debug levels increased to show the following when it was broken:

[May 22 17:43:46] DEBUG[22707] rtp.c: - RTP 2833 Event: 00000020 (len = 4)
[May 22 17:43:46] DEBUG[22707] rtp.c: Sending dtmf: 0 ([May 22 17:43:46] DEBUG[22707] channel.c: Got DTMF begin on channel (SIP/xxxxxxxxx-08285d58)

Why it works on the one platform, but not the other when I had some of the DTMF features enabled is beyond me, but it works now, so I’m happy.