Extensions are always 'in use'


#1

Hi, just setting up a new asterisk install. have setup 3 extensions, and when calling any of them from xlite, it always says the extension is in use. ive searched google but didnt find anything that helped. can anyone help me out?

thanks.

also, i forget what the command is to have asterisk spit out what is happeneing, like if i call an extension, i want it to print out what it is doing.


#2

start asterisk like this asterisk -vvvvc then you can see what its doing


#3

ok seems like asterisk starts fine when i do

running asterisk -vvvvc returns:
Unable to open pid file ‘/var/run/asterisk/asterisk.pid’: No such file or directory
Unable to bind socket to /var/run/asterisk/asterisk.ctl: No such file or directory
== Parsing ‘/etc/asterisk/asterisk.conf’: Found
== Parsing ‘/etc/asterisk/extconfig.conf’: Found
Asterisk CVS-v1-0-09/14/05-19:59:25, Copyright © 1999-2004 Digium.
Written by Mark Spencer markster@digium.com

== Parsing ‘/etc/asterisk/logger.conf’: Found
Asterisk Event Logger Started /var/log/asterisk/event_log
== Manager registered action Ping
== Manager registered action Events
== Manager registered action Logoff
== Manager registered action Hangup
== Manager registered action Status
== Manager registered action Setvar
== Manager registered action Getvar
== Manager registered action Redirect
== Manager registered action Originate
== Manager registered action Command
== Manager registered action ExtensionState
== Manager registered action AbsoluteTimeout
== Manager registered action MailboxStatus
== Manager registered action MailboxCount
== Manager registered action ListCommands
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found

Also, why are all of these processes running???:
root 1869 1 0 07:28 ? 00:00:00 /bin/sh /usr/sbin/safe_asterisk
root 1915 1869 0 07:28 ? 00:00:00 /usr/sbin/asterisk -vvvg -c
root 1947 1915 0 07:28 ? 00:00:00 /usr/sbin/asterisk -vvvg -c
root 1949 1947 0 07:28 ? 00:00:00 /usr/sbin/asterisk -vvvg -c
root 1950 1947 0 07:28 ? 00:00:00 /usr/sbin/asterisk -vvvg -c
root 1951 1947 0 07:28 ? 00:00:00 /usr/sbin/asterisk -vvvg -c
root 1952 1951 0 07:28 ? 00:00:00 /usr/sbin/asterisk -vvvg -c
root 1953 1947 0 07:28 ? 00:00:00 /usr/sbin/asterisk -vvvg -c
root 1954 1947 0 07:28 ? 00:00:00 /usr/sbin/asterisk -vvvg -c
root 1955 1947 0 07:28 ? 00:00:00 /usr/sbin/asterisk -vvvg -c
root 1959 1947 0 07:28 ? 00:00:00 /usr/sbin/asterisk -vvvg -c
root 1980 1947 0 07:28 ? 00:00:00 /usr/sbin/asterisk -vvvg -c
root 1981 1947 0 07:28 ? 00:00:00 /usr/sbin/asterisk -vvvg -c
root 1982 1947 0 07:28 ? 00:00:00 /usr/sbin/asterisk -vvvg -c
root 1983 1947 0 07:28 ? 00:00:00 /usr/sbin/asterisk -vvvg -c
root 1984 1947 0 07:28 ? 00:00:00 /usr/sbin/asterisk -vvvg -c
root 3155 3122 0 08:03 pts/2 00:00:00 grep asterisk


#4

Do you have some phone, soft or hard, connected to those extensions ?
Try command: sip show peers in the CLI and check if you have phone registered to those extensions.

Looks to me like you’re not having any phone registered to the extensions. What you get exactly ? A voice message saying your party is currently busy or something like that ?


#5

Can you call from extension to extension ?


#6

ok so i installed AMP and now it magically works - I have another problem tho, I cant get music on hold to work now! how can i make asterisk always write its log to the console window so i can catch errors and such?


#7

everything is working now on this front - thanks.


#8

I have the same problem, I can’t call from extension to extension, allways says the extension XXX is on the phone please leave your message…

I’ve tried sip show peers and the result :
Name/username Host Dyn Nat ACL Mask Port Status
202/202 192.168.0.3 D N 255.255.255.255 6018 OK (83 ms)
200/200 192.168.0.129 D N 255.255.255.255 7152 OK (94 ms)

If I try to make a call from my softphone (logged in my astersik) to an external asterisk server, i can talk and everything is fine, but if i try to call from an external asterisk to my asterisk, the result is that the extension is in use

thanks


#9

I’m having a similar issue with my second Aserisk box. The first one is working fine but the second (for a different company in the same office) is saying everyone’s line is busy and then forwarding to voice mail. The funny thing is that outgoing calls work just fine.


#10

What PC spec that u have? I think u need to adjust ur BIOS settings.


#11

Just wanted to add that the very reason I looked for this forum and signed up was that I was having the same issue. It seems from reading these posts this could be a somewhat common problem, probably due to a config error maybe?

For me, I get this error calling any extension that is NOT connected. But when someone connects with a softphone and I dial the extension. Yet when I dial an extension that is NOT connected I get the regular voicemail.

Problem with this error I found that it is not specific enough, by that I mean it is really hard to do a search on the internet. If anyone does find an answer please let us know.


#12

Well what i encountered is my BIOS options. I bought a new PC with intel P4 hyper threading and when i install Asterisk on it, the line always says busy. I uninstall and reinstall but to no avail. Finally i fixed it by disabling the Dual … options in the bios ( i forgot the name already). This might be your problem. :confused:


#13

That is really strange. Let us know if the problem re-occurs. I might point out that my hardware is a dual Intel P3. Could this be an issue with SMP enable servers?