Escape characters in log output

Hello,

I’m using asterisk 1.6.0.1 on Debian etch. I’m seeing weird escape-like characters in the messages log when viewed using the ‘less’ command. Is there a fix or setting to change in logger.conf that makes this go away or behave like previous versions?

This is my setting in logger.conf:
messages => dtmf,notice,warning,error,debug,verbose

Here are some examples:

Oct 17 13:22:44] VERBOSE[4376] logger.c: == Registered application ‘ESC[1;36;
40mParkAndAnnounceESC[0;37;40m’
[Oct 17 13:22:44] VERBOSE[4376] logger.c: app_parkandannounce.so => (ESC[33;40m
Call Parking and Announce ApplicationESC[0;37;40m)
[Oct 17 13:22:44] VERBOSE[4376] logger.c: == Registered application ‘ESC[1;36;
40mPickupChanESC[0;37;40m’
[Oct 17 13:22:44] VERBOSE[4376] logger.c: app_pickupchan.so => (ESC[33;40mChann
el Pickup ApplicationESC[0;37;40m)
[Oct 17 13:22:44] VERBOSE[4376] logger.c: == Registered application ‘ESC[1;36;
40mPlaybackESC[0;37;40m’
[Oct 17 13:22:44] VERBOSE[4376] logger.c: app_playback.so => (ESC[33;40mSound F
ile Playback ApplicationESC[0;37;40m)
[Oct 17 13:22:44] VERBOSE[4376] logger.c: == Registered application ‘ESC[1;36;
40mPrivacyManagerESC[0;37;40m’
[Oct 17 13:22:44] VERBOSE[4376] logger.c: app_privacy.so => (ESC[33;40mRequire
phone number to be entered, if no CallerID sentESC[0;37;40m)

[Oct 17 21:07:02] VERBOSE[6593] logger.c: – Executing [s@incoming:4]
ESC[1;36;40mGotoIfTimeESC[0;37;40m(“ESC[1;35;40mDAHDI/3-1ESC[0;37;40m”, “ESC[1;3
5;40m19:40-23:59,,,*?open,s,1ESC[0;37;40m”) in new stack

Yes, I know, replying to my own post is bad but in case anyone else runs into this problem the solution is to add the following to asterisk.conf in the [options] section:

nocolor=yes