Error while reinstalling Asterisk 11 on Ubuntu 12.04 Vmware

I followed the instructions on and managed to install Asterisk 11 on Ubuntu 11.04 serve edition.

After installation I got "Illegal Instruction " error when I tried to start it using $ /usr/sbin/asterisk -cvvv command

After few mins of googling I got a suggestion to run the menuselect again and to remove the BUILD_NATIVE from Compiler Flags.

I done it and tried to make and install the source again but it failed with below error

The error says like fatal error: jitterbuf.h : No such file or directory
Compilation terminated

Also I am having a time skew error, kindly assist me to fix this

Always look for the first error!

Until you have tried building without a clock skew, I don’t think you can rely on any other errors.

Basically, the time on your virtual machine is earlier than the latest time on a file in the source tree.

Hey ,
thanks for the response and I checked the /etc/ntp.conf file
It is configured with ubuntu servers

The time showing is Oct 4 09:17:47 PDT 2013 in the Linux machine but the actual time now here is 9:48 PM

What should I do now to fix issue with timing ? shall I just change the system time or should I add some other server instead of ubuntu in conf file ?

Configured time zone again using
sudo dpkg-reconfigure tzdata

Will try to compile and install the source code again

Changing the time zone fixed the issue :smiley:

Now I am able to start and work in the CLI …

Thanks a lot for your help

The timezone should have no effect. Both Unix (including Linux) and NTP work in UTC. It is more like that you let the time advance until it was no longer earlier than the latest time in the source tree.