Error compiling asterisk-1.4.10.1

I get the following error when compiling asterisk-1.4.10.1 on debian:

ast_h323.cxx: In destructor ‘virtual MyProcess::~MyProcess()’:
ast_h323.cxx:194: error: ‘timerChangePipe’ was not declared in this scope

Earlier I had tried compiling asterisk-1.4.9 and I got the same error.

Could someone help in fixing this problem?

Thanks,
Raj Mohan

I fixed the problem by defining :

 sttaic int timerChangePipe = {14, 15};

in ast_h323.cxx.

I got these magic numbers from a gdb backtrace on the web. I know that this is not the correct
way to fix the problem.

Could someone please advise me on the correct fix.

Thanks & regards,
Raj Mohan

Seems you don’t have the right version of the pwlib library.

Bye.

Marco Bruni

I am using pwlib v1.11.3. Isn’t the minimum requirement pwlib v1.10.0?

Thanks,
Raj Mohan

Since the values in timerChangePipe array are descriptors for pipes, my fix will not work.
I can only fix the problem by getting hold of the correct version of pwlib. I checked the source code of pwlib-1.11.3 and there is no reference to the variable timerChangePipe.

Could someone tell me which version of pwlib to use with Asterisk 1.4.10?

Thanking yu,
Raj Mohan