Echocorrection problem on AVM C4 and DigiumB410p

my problem is that I have a customer who complains about echo all day (80% of the calls) and I can do nothing from my office.
I use AVMC4, so CAPI and I’ve enabled echocancelold=yes,tail=64 - by the way should I use echocancel=yes as well?
Should I enable nt mode?

SuSE 10.0, Asterisk 1.12.13, ChanCAPI 1.0.0

I thought that the problem was caused by the AVM-C4, but yesterday I’ve replaced it with a Digium B410P which has the same problem even if it has Echo Correction.
Asterisk 1.2.17

Changing gain fixed some of echo problems.