Echocancel=yes still there is an echo

Within our LAN we have:
1 SIP server with a x100p card
4 X-Lite SIP softphones

Calls between the softphones are ok.
Calls between the softphones and ATA are ok.

But calls via the x100p have an echo.
I can hear my voice echo on the softphones and the ATA.
The person on the other end of the line cannot hear any echo.

The “/etc/asterisk/zapata.conf” contains:

What is causing this echo?
How do I suppress this?

the wiki is your friend ! … ncellation might help you get started.


Mayby you could help me with my echo issue? This is what I’ve done already: … highlight=

short of purchasing a card with echo can built in, there is no quick fix to echo. it’s a matter of trying the different cancellers, tweaking your zap gains and crossing everything you have. you can move a known-working system and FXO card to a different motherboard and experience huge echo.

to put it bluntly- x100 cards suck.

try the mark2 echo canceller and switching on aggressive echo cancellation (zaptel source, requires recompiling zaptel). Turn on echotraining in zapata.conf. Hopefully this will help…