Echo + packetization interval

Hello * people,

For the people who still have problems with echo, I found a solution for our echo problems.
It might help you, maybe not. You can try it at least :laughing:

The default packetization interval for alaw, ulaw and G729 within Asterisk is 20ms.

The default packetization interval setting for Aastra IP Telephones is 30ms.

After I set the Aastra IP telephone to 20ms the echo on ISDN calls disappeared.
So the problem seemed to be the Aastra telephone.
Maybe other brands (like Polycom) have the same default setting (30ms)

Just to make sure I also set correct parameters in sip.conf, though this should already be the default in Asterisk

allow=alaw:20,ulaw:20,g729:20

Extra info;
http://www.voip-info.org/wiki/view/Asterisk+Documentation+1.6.1+rtp-packetization.txt

Regards,

Hendrik vd Ploeg
The Netherlands