DTMF numbers being dropped

It appears that DTMF numbers are sometimes dropped by asterisk.

Pastebin of RTP Debug. This is a call between two local extensions on a local network. 10.10.10.249 typed 3, 2, 1. Asterisk relayed the key presses to 10.10.10.103: 3, 1. If you look at the log, Asterisk clearly received 3, 2, 1, but only sent 3, 1.

This seems to happen randomly, and more often if you type the numbers more quickly. Both extensions are set to use rfc2833, and you can see from the log that the packets are being sent out of band. I saw this originally happen on 1.4.40; I upgraded to 1.8.4 RC to try to resolve it (I tried 1.8.3, it segfaulted on startup), and this is still occurring. Based on various things I’ve found on google, I’ve tried constantssrc=yes, session-timers=refuse, rfc2833compensate=yes in various combinations, to no effect. Any ideas on what the issue may be, or how I can resolve it?

I’m having the same issue on all outgoing calls.
This bug was introduced in version 1.4.40 which according to the change log had a lot of DTMF related work done.