DPMA Possible on FreeBSD?

Hi,

I’m currently planning out my first Asterisk install. For some context, I have significant Linux/Unix administration experience, and a decent but not impressive amount of VoIP/Telephony experience (mostly with our old Avaya system). The system will be a pretty straightforward PBX for the office (SIP endpoints, SIP trunk upstream). Most of the endpoints will be D65 phones, and I’m intending to use some of the DPMA features.

My problem is that I’ll be running FreeBSD as the OS for the server. DPMA is only compiled for Linux it seems.

In my eyes, the best possible solution would be to convince Digium/Sangoma to produce FreeBSD binaries for DPMA. Can anyone here speak to the likelihood of this ever happening?

The next best idea I have is to run all of Asterisk in the Linux Emulation layer - I’ve worked out that there’s no way to mix a Linux shared library with a Freebsd binary, so I’d have to go “all-in”. I’d be surprised, but does anyone have any experience with this method? In particular, some hints as to what versions of things to try would go a long way - otherwise I’ll start experimenting, probably with the Centos7 compat stuff first.

Short of that, I’ll probably BHYVE my way out of this, but I was so hoping to avoid virtualization on this system (not that it can’t handle it).

Thanks in advance for any info which might make this job easier!

Hi,

I managed to figure this out. I won’t be that guy that says that much and quits, here’s what I did:

First, native DPMA is out - I did confirm this with support. Time to pull out some linux(4).

I decided at this point that it would be much easier to manage an entire chroot rather than individual packages. Following the instructions at LinuxJails - FreeBSD Wiki I was able to create a Ubuntu Focal chroot. From this environment, I installed asterisk from source the typical way. The only issue I ran into with registering the license was that asterisk doesn’t automatically create /var/lib/asterisk/licenses, causing the message “Couldn’t get license from server” after running through all the steps. Just make this folder yourself and you should have no issues.

So far I haven’t run into anything this setup can’t do compared to a normal native Linux setup. Just letting you guys know that this is not only possible, but it’s downright easy compared to what I expected. My guess is that everything would run fine without the whole chroot, but you’d need a way to generate the linux binaries for asterisk that you need anyway - this is just an easy way to make sure you have everything you need, and should prove easier to manage in the future.

EDIT: I can’t get avahi to work, but I’m not putting too much time into it, since DHCP Option 66 can point a phone to DPMA.

So far (I’ll try to update this if I find any other good options), the configure command has to look like:
USE_GETIFADDRS=“no” ./configure --without-inotify