Does asterisk and asterisk-gui need selinux

with asterisk 1.4.22 and asterisk-gui 2.0 do we need selinux enable or disable. We are having problems with disabling selinux as our server is crashing. We were trying to disable it for freepbx 2.5.0 as this was one of their requirements for centox 5 OS. we are using centos 5.2

What type of problems have you got disabling selinux?
I haven’t much experience with asterisk gui 2.0 -

with freepbx, it requires selinux disable. when we tried to disable selinux, our server would not reboot.

I am not sure if asterisk or asterisk-gui needs selinux disable. I have asterisk 1.4.22, asterisk-gui 2.0 installed successfuly. Haven’t tried to add things though.

We would like to install freepbx because it comes with ARI and FOP. Plus it has a few more modules like CustomContents.

OK. Why doesn’t the server reboot? At what stage does it get etc…
I haven’t had that happen to me ever, so you’ll probably have to look into that on google or some selinux/linux questions website.