Digium TE4xx to VoIP gateway

We’ve got a digium TE4xx something card. It works fine. I’ve connected T1s from a legacy box to it, and it accepts the calls properly.

I’ve also got the machine set up to accept inbound or make outbound VoIP calls. This also works fine.

Now, I’m trying to convert this into a gateway. I’ve got some legacy PRI T1-based equipment, that I’m trying to set up to do outbound calls via the gateway. My existing config mostly works, but either I’m doing it not quite right, or perhaps there is a better way altogether.

I think my entire problem boils down to the proper config for extensions.conf, but not positive. I’ve spent quite a bit of time looking for information on setting up a gateway of this type and really haven’t found any… which surprises me, so maybe I’m just not looking in the right places.

My current config is something like:

exten => s,1,Dial(SIP/voip_out/${EXTEN})
exten => s,2,Answer
exten => s,102,Busy
exten => t,1,Hangup

Oh, and outbound calls ARE WORKING, but the problem is with calls other than normally-answered calls, like busy (or intercept, which I haven’t tested at all yet).

For a little personal context, I’ve been using * without serious problems for nearly 2 years. But I’ve been using AGI for most of it. Once I got AGI working, I’ve avoided touching extensions.conf, so I’m not as familiar with it as I could be.

Okay, I’m a little astonished that no one has done this, and able to offer any suggestions… Posting a reply to bump this for a few more days before giving up… :frowning:

dump everything but the first line. That should pass the call status back to the originating caller. THe problem right now is that after you Dial(), if that doesn’t go thru (IE busy) it moves onto the next priority (Answer()). Priority jumping (n+101) is considered bad and won’t be done unless you use the ‘j’ flag on the dial statement.

Thanks. That certainly works better than what I had.

I’m now running into problems with intercepts but this looks like a deeper problem…