Digium TE435BF and Elastix 4 - PRI Spans unknown

We have installed the latest Elastix 4 on our Server with two Digium TE435BF Cards. Our Problem is that the Hardware Detector shows Unknown PRI Spans, the color of the Spans is green and “Detectet by Asterisk” but unknown.

We have a E1-Setup and so we included the parameter “options wcte43x default_linemode=e1” in the dahdi.conf file as described in the manual of the Digium Card.

When i tipe “lsdahdi” in the command line i get also the “unknown” status.

Curious is, that all seems working. We Did In- and Outboundcalls and all seems fine. But i have stomach ache to use the Elastix with that unknown Status.

Has anybody out there a solution or a tip for us?

If those are current supported products, contact the supplier or manufacturer. Digium don’t support their commercial hardware on the community forums.


We also don’t have any idea what Elastix is doing in any of its web pages, so we can’t comment on that. If there’s a page in Elastix and it’s not showing what one would expect, the best place to start is with Elastix.


Hey Guys,

thanks for your input.

But first we see no problem in Elastix. As you can see in the following screenshot:

We allready get the “Unknown-Message” in the CMD and that´s Asterisk as i may to know. Looks like a DAHDI Problem. We use DAHDI version 2.10.2 but also tried a newer one with the same result.

Best regards

You must configure the card, this card comes to an BRI default configuration, if you need PRI

T1/E1 Selection
options wcte43x default_linemode=e1

you can find out more https://www.digium.com/sites/digium/files/quad-span-digital-card-user-manual.pdf

Page 25

I hope you can fix this issue

PD: Try DAHDI Version:

1 Like

Hey Gatozero,

Thanks for your help.

We did setup the dahdi.conf like described in the manual.

We have tried Dahdi version without any changes to our spans.

I found out that Elastix 4 uses libpri 1.4.15 and there is a new version ( 1.5.). So we did an update with “yum update”. Libpri is now on 1.5. but after all, nothing changed.

Like mentioned earlier, contact Digium tech support. That will be able to help you get this resolved much quicker than on the forum, and you pay for this support when you buy a Digium card.

Best wishes,
Matthew Fredrickson

1 Like