Digium TE220b & asterisk


#1

Can someone tell me haw can I swich on/off echo canceler in Extensions conf (asterisk 1.6.2.21)

Line exten=>67076794,6,Set(CHANNEL(echocan)=0);exten=>67076794,6,Set(CHANNEL(echocan)=1) dosen’t works…

[Dec 12 10:18:39] WARNING[15703]: app_playback.c:471 playback_exec: ast_streamfile failed on DAHDI/3-1 for menu/avarija
– Executing [67076794@DID_span_1:6] Set(“DAHDI/3-1”, “CHANNEL(echocan)=0”) in new stack
[Dec 12 10:18:39] WARNING[15703]: func_channel.c:331 func_channel_write_real: Unknown or unavailable item requested: ‘echocan’


#2

I do not believe it’s possible to control the echocan from the dialplan. You will need to disable it in /etc/asterisk/chan_dahdi.conf.