Digium g729a under FBSD5.5 Copy Protection error?

Hi Guys…

Asterisk 1.4

licensed g729a digium codec…

downloaded the latest unsupported FBSD5.5 codecs from the digium ftp for ast1.4… and the new register app… ran and registered fine…

.lic file is in the /var/lib/asterisk/licenses directory…

moved codec to the /usr/local/lib/asterisk/modules and stopped and restarted AST…

Ive tried the i386/i586/i686/P2/P3 all the same… (machine is Intel P3)

[Jul 19 11:34:12] NOTICE[5618]: codec_g729.c:403 load_module: G.729 transcoding module version 32, Copyright © 1999-2007 Digium, Inc.
[Jul 19 11:34:12] NOTICE[5618]: codec_g729.c:407 load_module: This module is supplied under a commercial license granted by Digium, Inc.
[Jul 19 11:34:12] NOTICE[5618]: codec_g729.c:408 load_module: Please see the full license text supplied by the accompanying
[Jul 19 11:34:12] NOTICE[5618]: codec_g729.c:409 load_module: “register” utility, or ask for a copy from Digium.
[Jul 19 11:34:12] NOTICE[5618]: codec_g729.c:410 load_module: This product includes software developed by the OpenSSL Project
[Jul 19 11:34:12] NOTICE[5618]: codec_g729.c:411 load_module: for use in the OpenSSL Toolkit. (openssl.org/)
[Jul 19 11:34:12] NOTICE[5618]: codec_g729.c:412 load_module: Copyright © 1998-2006 The OpenSSL Project

== G.729 Host-ID: 2b:20:eb:64:6e:e2:6b:09:f8:be:ff:77:e6:b7:2e:dd:fb:8c:37:73
[Jul 19 11:34:12] WARNING[5618]: codec_g729.c:420 load_module: Failed to initialize G.729 copy protection!
codec_g729a.so => (Annex A/B (floating point) G.729 Codec (optimized for i586))

Host-id matches the asthostid app / MAC for only Nic in machine…

anyone help ??


Did you get this fixed? I have the same problem on Solaris with version 32 of the G729a codec.

Did you get this fixed? I have the same problem on Solaris with version 32 of the G729a codec.

yeah i ended up contacting digium direct who used the standard ‘Sorry we dont support Freebsd’… which helped a lot…

I ended up having to roll back to asterisk 1.2.x and used my original licensed codec… and it worked fine… its still on my todo list…


Hello! Is any chance for solution?
The same problem on FreeBSD 6.1
Asterisk 1.4.11 with licensed g729a digium codec