'digits/day-5 does not exist' -- but it does!

THE SETUP: Centos 7, Certified Asterisk 16, Sangoma A102 driving a pair of Adtran 850 channel banks (all FXS cards), Sangoma A200 ‘Remora’ handling our single copper POTS line.

THE PROBLEM: Two, actually. First, and most critical, is something’s off with voicemail retrieval. For whatever reason, the system thinks the sound files ‘digits/5’ and ‘day-5’ don’t exist, and any attempt to retrieve voicemail bombs out when the script hits that point. Here’s a CLI trace.


– Starting simple switch on ‘DAHDI/1-1’
– Executing [19600@pots-int:1] VoiceMailMain(“DAHDI/1-1”, “9555@house”) in new stack
– <DAHDI/1-1> Playing ‘vm-password.ulaw’ (language ‘en’)
– <DAHDI/1-1> Playing ‘vm-youhave.ulaw’ (language ‘en’)
[Apr 16 18:28:43] WARNING[8158][C-00000001]: file.c:779 ast_openstream_full: File digits/5 does not exist in any format
[Apr 16 18:28:43] WARNING[8158][C-00000001]: file.c:1252 ast_streamfile: Unable to open digits/5 (format (ulaw)): No such file or directory
– <DAHDI/1-1> Playing ‘vm-INBOX.ulaw’ (language ‘en’)
– <DAHDI/1-1> Playing ‘vm-messages.ulaw’ (language ‘en’)
– <DAHDI/1-1> Playing ‘vm-onefor.ulaw’ (language ‘en’)
– <DAHDI/1-1> Playing ‘vm-first.ulaw’ (language ‘en’)
– <DAHDI/1-1> Playing ‘vm-message.ulaw’ (language ‘en’)
– <DAHDI/1-1> Playing ‘vm-received.ulaw’ (language ‘en’)
[Apr 16 18:28:49] WARNING[8158][C-00000001]: file.c:779 ast_openstream_full: File digits/day-5 does not exist in any format
[Apr 16 18:28:49] WARNING[8158][C-00000001]: file.c:1252 ast_streamfile: Unable to open digits/day-5 (format (ulaw)): No such file or directory
[Apr 16 18:28:49] WARNING[8158][C-00000001]: say.c:470 wait_file: Unable to play message digits/day-5
== Spawn extension (pots-int, 19600, 1) exited non-zero on ‘DAHDI/1-1’
– Hanging up on ‘DAHDI/1-1’
– Hungup ‘DAHDI/1-1’


I’ve checked for the presence of the sound files. They are most definitely present, matching case, matching names, in just about every format Asterisk supports (including ulaw). I’ve also tried letting Asterisk run as root, rather than as user/group asterisk. No luck.

I’ve never seen this in any Asterisk system I’ve built to date. Our previous ver. 13 machine works perfectly, same setup.

What the blazes am I missing?! Is this an actual bug, or…???

Second problem: I’ve got ODBC set up to have the system record CDR data to a local MariaDB (mysql) database. The data’s getting written, but the ‘datetime’ field always comes up all zeros. What the blazes…?!

Thanks much.

Test trying to play the file directly specifying the full path, to make sure asterisk is looking for on the correct path

Path is define onthe /etc/asterisk/asterisk.conf

it is recommended do not post multiples issues ona single thread, to keep things organized and also dont post multiples post in a single day, to avoid a single user flood the forum with all his issues

Now Answering your question make sure the DB colum type for date is set to the correct data type, one thing you can do to make sure is make a manual insert

Fair enough. One issue at a time it is, and thanks.

Anyway – On the playback issue, here’s what I get when I try for direct playback in response to dialing a fixed extension (a test extension, to be exact):

– Starting simple switch on ‘DAHDI/3-1’
– Executing [10060@pots-int:1] Answer(“DAHDI/3-1”, “”) in new stack
– Executing [10060@pots-int:2] Playback(“DAHDI/3-1”, “/var/lib/asterisk/sounds/en/digits/day-5”) in new stack
[Apr 16 21:14:20] WARNING[15669][C-00000006]: file.c:779 ast_openstream_full: File /var/lib/asterisk/sounds/en/digits/day-5 does not exist in any format
[Apr 16 21:14:20] WARNING[15669][C-00000006]: file.c:1252 ast_streamfile: Unable to open /var/lib/asterisk/sounds/en/digits/day-5 (format (ulaw)): Permission denied
[Apr 16 21:14:20] WARNING[15669][C-00000006]: app_playback.c:492 playback_exec: Playback failed on DAHDI/3-1 for /var/lib/asterisk/sounds/en/digits/day-5

What the actual ??? ‘Permission Denied?’ Since when?! That directory, and all its subdirectories as well as all the sound files, have ‘asterisk:asterisk’ as their owner. How could this possibly be a permissions issue?

chmod -R 755 /var/lib/asterisk/sounds/en/

I’ll be darned… It fixed it! Thank you so much!

Any idea why it needed this? I would think ownership of the files by the ‘asterisk’ user and group would have been enough.

A little ‘bit’ generous with the execute bit? :smiley: :smiley:

If this fixed the permissions issue did it fix the issue with just ‘digits/day-5’?

Any clue what the previous permissions were set to? (And how they got that way?)

Any chance ‘astvarlibdir’, ‘language’, or ‘languageprefix’ were hosed?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.