Dialplan stripping characters from string

I am trying to work with CID Prefixes for virtual queues and queues, and have run into an interesting phenomenon:

if VQ_CIDPP ends in one or more Colons : :: ::: or a semicolon ;. ot os stripped.

exten => 9,n,Set(QCIDPP={IF([{LEN({VQ_CIDPP})}>0]?${VQ_CIDPP}:Testing:)})

if i dont push a VQ_CIDPP, it successfully sets QCIDPP to “Testing:”
if i push VQ_CIDPP as “test:”, it sets it to “test”
so the logic is correct for the A/B switching, but it strips trailing colon and semicolons off of VQ_CIDPP when setting QCIDPP.

The syntax is Set(variable={IF([confition]?statement1:statement2)}). If you add the colon after Testing (it is part of a string), try to escape it with \

It’s a bug with the freepbx module I am using not encapsulating strings. I want the prefix to be “Name:” for some post processing later on.

I have a freepbx big open on this same issue to resolve.

Escaping the character works, as a workaround until the module can be corrected

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.