Dial out on VOIP?

I’d like to transfer users who dial into the asterisk VOIP system from land line phones to other land line phones. The orielly examples deal with connecting to other phone lines over a hard lined asterisk system, not voip.

Any examples anyone could post would be great.

it doesn’t make any difference … Asterisk doesn’t require any special setup. you simply use Dial() with the appropriate technology and destination details.

So if I’ve got a vanilla voip system, and I want to call 15551234567 can you tell me what the command should be?

I tried using the Dial command but it kept saying no such extension.

exten => [pattern],priority,Dial(SIP/${EXTEN}})

assuming its SIP.

I tried that with:
exten => 0,4,DIAL(SIP/15551234567,20,r)
And I get errors:

Oct 1 16:14:35 WARNING[7425]: chan_sip.c:1398 create_addr: No such host: 15551234567
Oct 1 16:14:35 NOTICE[7425]: app_dial.c:746 dial_exec: Unable to create channel of type ‘SIP’

I also tried it without the 20,r parameters, but it keeps giving the same error. No host, and can’t create channel (whatever I put in).

Any other ideas?

seriously ??? no log files, no configs and you want help ? go read the sticky at the top of the forum. what you want is dealt with in the book, examples abound in the wiki and the Asterisk example configs, but you want people here to hold your hand ?

I don’t mind the newbie /smack feedback, but the post above is directly from my conf file with the error I’m getting from my console log, which is exactly what you’re saying I should be posting.

As I said above, I went to the book first, and the examples that work for the hardware asterisk interfaces for Dial() doesn’t appear to be working for my voip setup. So I posted my exact code, and my exact error. AND the ZAP line I tried is straight from the wiki. Hence my confusion. And yeah, I googled it.

I’m glad that it’s supposed to be the same interface for both, but I’m clearly missing something in converting the examples over with copy/paste. If you have any ideas on what assumptions I am making between the vanilla example setups, and my vanilla build, I’m all ears. Right now, I think as the error states I’m not setting a channel right, which is what I’m looking for help on. If there is something else that I should have in here, like more of the conf file, or more log (the above is the only thing in it) I’ll put it.

Hope you can help, thanks.
(going off to read sticky and see what else I should be posting) //edit

What VOIP provider are you using?

voip provider is Voicepulse.

BTW -> Asterisk 1.07 on a mac OSX 10.4 box.
The entire function is:

exten => 0,1,Playback(transferring)
exten => 0,2,Setvar(NewCaller=${CALLERIDNUM})
exten => 0,3,SetCIDNum(0${CALLERIDNUM})
exten => 0,4,DIAL(SIP/5551236789,20,r)
exten => 0,5,hangup

Always dies on Dial with above errors.

first off, you’re going to find information in the wiki harder to locate as it’s slowly being cleared of pre-1.2 information. is there a reason you’re using 1.0.7 ?

the Dial() example you’re using would be suitable for a call to a locally registered device, i.e. you have a UA/phone registered with your Asterisk box for the number you are dialling. this clearly isn’t the case. if you’re attempting to reach an external number you need to dial the number @ the provider, or create a trunk definition (and register string preferably) and then use Dial(SIP/trunkname/number)

if you’d searched the wiki for “voicepulse” you would have found this voip-info.org/wiki/view/Aste … se+connect as a starter. if you look at the voicepulse homepage, then go to “Learn More” then “Knowledgebase” they even give you help with connecting Asterisk.

Didn’t realize my verison number was so far behind. Also didn’t think to look at Voicepulse, as I kinda figured I just screwed up the syntax. thanks for all the info in your post, let me go hit it and get back to u.

[SOLVED] Upgrading to the latest version fixed this.