Diable ZAP answer


#1

I have a X100P. I want to disable call answering altogether. I want to use the channel for outbound calling only and I don’t want * to respond to incoming calls.

Basically, I have my POTS line forwarded to my VOIP DID. When I receive a call on the POTS line, the line rings for a split second to indicate a forwarded call. The short ring, however, is enough to start the answer process going.

I already have a context that just hangs up the line as soon as it’s answered. However, I would like to just disable answering altogether.


#2

then make sure it doesnt answer at all ? Send it e.g. to a non existant context or so. Doesnt that do that trick ?


#3

Well, it doesn’t get answered unless you explicitly Answer() it - so just don’t do it. I’m not sure exactly what the caller will get if you do it, or if it can be done without answering it first, but you could try doing a Hangup() without an Answer(). Or do a Congestion(). There don’t seem to be any other options really, except what zoa suggests.


#4

I found that if you don’t have anything in a context to answer, then it won’t.
I had a dial plan where * would detect the ring and ring extensions, but the ZAP was not picked up until either an extention was answered or voicemail took over. To get this I just did not put answer() in the dial plan.

Hope this helps…