Delay on CDR update [solved]

I ran into a strange problem on Asterisk
I’ve got a context where I simply record a voicefile and play the review options. If the user decides to save the voicefile and presses 1, it always takes more than 3 seconds to jump to the next extension. It seems to hang on the CDR update. This is the CLI output:

 -- Executing [s@vm_record_memo:6] BackGround("SIP/196-087cacd8", "en/vm-review") in new stack
    -- <SIP/196-087cacd8> Playing 'en/vm-review.gsm' (language 'en')
  == CDR updated on SIP/196-087cacd8


exten => s,1,Background(${LANGUAGE}/vm-say_memo)
exten => s,2,Noop('Entered Memo record with ${UNIQUEID}')
exten => s,3,Set(LOOP=0)
exten => s,4,Record(/tmp/${UNIQUEID}.wav)
exten => s,5,Set(LOOP=$[${LOOP}+1])
exten => s,6(inv),Background(${LANGUAGE}/vm-review)
exten => s,7,WaitExten(3)
exten => s,8,GotoIf($[${LOOP}<3]?s,5:4,1)
exten => s,9,Agi(handlememo.agi,${mailaddress},${name})
exten => s,10,GotoIf($[${error}]=1)?100,1)
exten => s,11,Background(${LANGUAGE}/vm-memo_saved)
exten => s,12,Goto(vm_main_menu,s,1)

Any ideas what might cause the delay?

Solved -
I had extension 1 and extension 100 in the context. After removing extension 100 it works flawless.