Delay in outgoing call connection

I am having asterisk box connected to GoIP sim server when i make outgoing calls there is significant delay before the called part starts ringing. what could be the problem is it on asterisk configuration or GoIP side…

This is a property of GSM network. Try dialing with your GSM phone - you also have a big delay until the remote GSM phone starts ringing. And GoIP sim server is basically a GSM phone …

I have the same issue regarding the delay in outgoing call using the Goip GSM GW connected in asterisk. I think the issue is with the asterisk configuration and i am still seeking for the correct configuration. To isolate and verify which of the two (goip and asterisk pbx) is causing the delay ( in my part delay in outgoing call and not connecting the call to the pbx) i disconnect the goip from the pbx (asterisk) and directly connect a ip phone, i continued to monitor it’s perfomance i try dialing out with no delay, i call in and the ip phone ring immediately. i keep this set up for about two days and the connection is stable. Then, i reconnect the goip gsm gw back to the pbx and the same issue occurs. Here’s what i am experiencing:

  1. When trying to call out the mobile phone you are trying to call doesn’t ring until the ring timeout ends, then after some few seconds the mobile phone will then ring but there is no one at the other end (voip) because the ring timeout already expires on the pbx side.

  2. When i tried to call in using mobile phone —> goip —> pbx i can only hear continous ringing but the call is not terminating, i use an IVR in the pbx for testing purpose just to know that my calls are being connected to the pbx.

Here’s my network set up:

internet —>goip —> pbx —> extensions

But, the connections of all my extensions are ok, they are stable even the remote extensions are all working fine. only the asterisk to goip is having these issue. Can somebody kindly help us? I’ve been trying to contact the ip pbx vendor but they are not replying tried to email them a few times but still no reply. By the way I am using this ip pbx … 74&id=3090

Please provide your configuration and at least the protocol trace from sip set debug on. Preferably edit the trace to exclude everything except INVITE, BYE and responses to those. Please use a code block on the forum, so we don’t have to scroll through large amounts of text to follow the thread.

Please enable millisecond timing, and the full log, in logger,conf, and use the full log, not a screen scrape.

The only thing I can think of that would delay SIP would be a faulty DNS configuration, which is an OS level thing, not an Asterisk one.

Update guys, my issue with the goip to asterisk is solved. I updated the firmware of my pbx and now it is working properly,performance is stable and the issue regarding the delay in outbound call is fixed also, thank you david55 for your help! cheers!

I’m experiencing the same problem. Can you share the details how you solve the issue, as I’m not sure what do you mean by updating the pbx firmware. I’m running freepbx distro (centos) on x86 hardware. Thanks