Debian Box with Asterisk 1.6 and TE122P freezes

Hi,
I have a Debian box running Asterisk on a PRI.
The system is becoming more and more unstable.

The system Runs:

  • Debian Stable , all packages beside Asterisk, dahdi and digium card driver are from the Debian repos

  • Apache / Mysql

  • Asterisk 1.6.0.9

  • TE122p single PRI card

Here a record of recent uptimes…


pbx-root-22:36:22 ~ -> uprecords
     #               Uptime | System                                     Boot up
----------------------------+---------------------------------------------------
     1    43 days, 21:49:51 | Linux 2.6.18-6-amd64      Tue Feb 24 13:22:17 2009
     2    12 days, 00:33:59 | Linux 2.6.18-6-amd64      Thu Apr  9 12:24:39 2009
     3     9 days, 06:16:27 | Linux 2.6.18-6-amd64      Sat May  2 12:24:09 2009
     4     5 days, 22:20:19 | Linux 2.6.18-6-amd64      Tue Apr 21 13:03:05 2009
     5     5 days, 19:59:56 | Linux 2.6.18-6-amd64      Wed May 13 17:31:47 2009
     6     2 days, 14:39:29 | Linux 2.6.18-6-amd64      Wed Apr 29 21:43:30 2009
     7     1 day , 16:47:37 | Linux 2.6.18-6-amd64      Sat May 23 09:57:55 2009
     8     1 day , 07:50:30 | Linux 2.6.18-6-amd64      Tue May 12 09:33:50 2009
     9     1 day , 03:49:04 | Linux 2.6.18-6-amd64      Mon Apr 27 11:38:21 2009
    10     0 days, 21:15:59 | Linux 2.6.18-6-amd64      Tue Apr 28 15:40:54 2009
----------------------------+---------------------------------------------------
->  11     0 days, 12:46:14 | Linux 2.6.18-6-amd64      Mon May 25 09:50:13 2009
----------------------------+---------------------------------------------------
1up in     0 days, 08:29:46 | at                        Tue May 26 07:06:10 2009
no1 in    43 days, 09:03:38 | at                        Wed Jul  8 07:40:02 2009

As you can see the system is going down more and more often.

It’s very hard for me to debug the error.

Because i already changed the power supply and checked the RAM i asume it might be Asterisk causing the trouble.

if a freeze occurs, the whole system freezes, network goes down, console on ttys freezes with random garbage on screen. the only way to get it back to life is to cut the power and reboot.

The logs show nothing. There seems to be nothing special happening before the freeze.

If there was a bug in asterisk 1.6, the te122p or any of the drivers, maybe someone else has had these problems too?

i don’t want to get a whole new server, before knowing what causes the trouble.

thanks
wonder

Hi

If you have made no other changes to the system why would it be becoming more unstable ? You need to look at things such as log files etc and make sure they are rotating correctly.

Does just Asterisk freeze or the whole server ?

It seems odd that a restart is only letting the runtime get shorter and shorter

Ian

Hey, the whole machine freezes, not just asterisk.

i checked many logfiles to see what was going on, but i couldn’t find any suspicious entries.

/var/log/messages
/var/log/error.log

and all the asterisk logs

It was a temperature problem with the server case…