DAHDI/Zaptel for Asterisk in OpenVZ/VServer (/proc issue)

Debian Lenny 2.6.26-2-openvz-amd64 with DAHDI 2.2.0. VE is debian-5.0-amd64-minimal with Asterisk (also tried vserver)

Installing DAHDI or Zaptel on HN works perfectly. Inside the VE, however, things aren’t working out. I have made available all the required /dev/dahdi or /dev/zap enties with proper perms and the one thing that is missing in order for Asterisk to see the timing device is /proc/dahdi or /proc/zap within the VE. On the HN…

vps1:/vz# cat /proc/dahdi/1
Span 1: WCFXO/0 “Generic Clone Board 1” (MASTER) RED


(yes I have hardware, but I also tried all this with ztdummy/dahdi_dummy with the same problems)

However, in the VE, there is no /proc/dahdi/1 file at all. When Asterisk starts it acts as if everything is fine but none of the DAHDI commands are available and the Meetme application does not function properly (Asterisk DID install with Meetme app).

Since I have all my devices set up properly in the VE, I think all I need to make this work is the missing /proc entry. How on earth can I get this to happen? Is there a way to “fake” the file into /proc? Or, can I hack Asterisk to NOT look at /proc and maybe somewhere else instead?

If the root of my issue IS the /proc problem, would it be a bad idea for Asterisk to include some parameter in a config file to account for running Asterisk within VE’s?

I see many posts of others who seem to have this working, but they may be running older versions of Asterisk that might not be checking /proc for a timing device.

-Mike Walker

P.S. - There seems to be a rumor that it might be working on i386 arch but I can’t verify it at the moment. forum.openvz.org/index.php?&t=msg&goto=35554# msg_35554