Cyber mega phone 2k shows echo stream slowly


#1

Why my cyber mega phone 2k takes up to 2mins to show the echo stream?

Asterisk version: 15.4.1
Ubuntu version: 14.04
Repeat step: call the ‘echo’ extension

http.conf:

[general]
enabled=yes
bindaddr=0.0.0.0
bindport=8088
tlsenable=yes
tlsbindaddr=0.0.0.0:8089
tlscertfile=/etc/asterisk/keys/asterisk.pem

extensions.conf:

[default]

exten => echo,1,Answer()
same => n,StreamEcho(3)
same => n,Hangup()

exten => video-conference,1,Answer()
same => n,ConfBridge(6001)
same => n,Hangup()

exten => 200,1,Answer()
same => n,Playback(demo-congrats)
same => n,Hangup()

pjsip.conf:

[transport-wss]
type=transport
bind=0.0.0.0
protocol=wss

[6001]
type = endpoint
context=default
direct_media=no
disallow=all
allow=ulaw,vp8
aors = 6001
auth = auth6001
max_audio_streams=10
max_video_streams=10
webrtc=yes

[6001]
type = aor
max_contacts = 10

[auth6001]
type=auth
auth_type=userpass
password=1234
username=6001

[6002]
type = endpoint
context=default
direct_media=no
disallow=all
allow=ulaw,vp8
aors = 6002
auth = auth6002
max_audio_streams=10
max_video_streams=10
webrtc=yes

[6002]
type = aor
max_contacts = 10

[auth6002]
type=auth
auth_type=userpass
password=1234
username=6002

modules.conf:

[modules]
autoload=yes
noload => pbx_gtkconsole.so
load => res_musiconhold.so
noload => chan_alsa.so
noload => chan_console.so
noload => chan_sip.so

confbridge.conf:

[general]

[default_bridge]
type=bridge
video_mode=sfu

[default_user]
type=user
music_on_hold_when_empty=yes
music_on_hold_class=default


#2

you do not use chan_sip here.


#3

Yes, I was told in another thread about to disable the chan_sip, refer to: Cyber mega phone 2k only shows two videos


#4

If you have disabled chan_sip, it was pointless providing the contents of sip.conf, as it will be ignored.

Also, a this appears to relate to the same basic issue as your previous thread, starting a new thread just confuses readers.


#5

You need to specify explicitly codecs, not allow=all, to ensure what is going on and negotiated. You also need to provide the console output, the SIP trace (pjsip set logger on), and RTP trace (rtp set debug on).


#6

I use the vp8 / ulaw to reproduce the issue and refer to the log:
http://freeswitch.ml/file/log.tar
Sorry for send you the log this way because I’m new here and restrict from uploading the log.

By the way, it seems the echo stream not appears if I use the H264 instead.


#7

What is the log indicating? Are you doing this on the same network? Have you tried different browsers?

As for H264 it’s up to the browser to decode and encode the video, depending on the system this may or may not work, and may only allow 1 to be decoded at a time.

With WebRTC this is one of the things you have to do when deploying it and debugging - isolate where the problem is. WebRTC encompasses a lot of things and has a lot of moving parts.