Cubieboard A10 Dahdi install problems

I am trying to compile and install dahdi for the cubieboatd A10 but have the following error when I try to install.
OS is Debian wheezy

root@server1:/usr/src/dahdi-linux-complete- make all
make -C linux all
make[1]: Entering directory /usr/src/dahdi-linux-complete-' make -C drivers/dahdi/firmware firmware-loaders make[2]: Entering directory/usr/src/dahdi-linux-complete-’
make[2]: Leaving directory /usr/src/dahdi-linux-complete-' You do not appear to have the sources for the 3.4.67+ kernel installed. make[1]: *** [oct612x-lib] Error 1 make[1]: Leaving directory/usr/src/dahdi-linux-complete-’
make: *** [all] Error 2

The error describe the issue, you need the kernel sources and headers for your running kernel version.

The kernel mI am using is 3.4.67+ and am unable to install kernel sources.

Do you need DAHDI at all?

Good question… I am just trying to figure out standard installation. This is what I want to do. Asterisk with freepbx requirements.

  1. multiple voip account so want to transfer that to asterisk and use it to make and receive calls.
  2. Use some kind for gui frontend so won’t be difficuilt configure trunks etc.

Currently am running pbx in a flash on a computer and its setup to handle all my calls. Want to shut it down and setup cubieboard.

Standard configuration see everywhere is

Dahdi & Libpri are used for configure TDM and Digital Cards, I’m going to assume your arm board doesn’t have a minipci or pci bus/connector so you don’t need both libraries. Your arm-board will handle only SIP or IAX2 devices.

Dahdi used to be needed for timing, and is still needed for the superceded meetrme conference application. It is possible that FreePBX may still need it for the latter reason, but this is not a FreePBX support board.

Note you don’t need the full kernel sources. What you will need is a kernel driver development environment, often provided by kernel-devel packages.

thank you. I am going to try and install asterisk by itself. so what steps are recommended for installing asterisk only. Thanks .

Here is the error I am getting while compiling.

Configure: error: *** termcap support not found (on modern systems, this typically means the ncurses development package is missing)

You need the ncurses-devel package maybe for debian is libncurses-dev, but you can use the install_prereq script located in the scripts folder inside the source code of asterisk.

looks like i am moving ahead on this. am at the stage of make && make install. Will surely post if I was successful. Next step would be configuring extensions and voip accounts I guess. Can some one post what would be next steps if possible links.


Thanks all for all your help. I have succeeded in compiling and installing asterisk. Can I just copy my config file from my system already running asterisk / freepbx and load them here or do I need to modify them ?

Only if you have the same version of freepbx if you are using plain asterisk then you need to configure by hand.

i was with same problem, but my version is diferent dahdi-linux, and the same error:
You do not appear to have the sources for the…el6.x86_64 kernel installed.
others kernel and same error continuous…

yum groupinstall "Development Tools"
yum update

yum install bison bison-devel ncurses ncurses-devel zlib zlib-devel openssl openssl-devel gnutls-devel gcc gcc-devel gcc-c++ libxml2 libxml2-devel newt newt-devel sqlite sqlite-devel glibc glibc-devel readline readline-devel libtermcap libtermcap-devel make make-devel libtool libtool-devel libtermcap libtermcap-devel unixodbc unixodbc-devel perl perl-Net-SSLeay perl-Crypt-SSLeay doxygen curl-devel mlocate lynx tar wget nmap bzip2 mod_ssl crontabs vixie-cron speex speex-devel unixODBC unixODBC-devel libtool-ltdl libtool-ltdl-devel ImageMagick ImageMagick-devel ImageMagick-perl

both installed and updated and reboot, but error continuous…
the same messenger show too in others kernel versions and all are update last version,

but after hours trying a solution, i fixed it error msg, using this dahdi (live):

svn checkout dahdi-linux
svn checkout dahdi-tools
cd dahdi-linux
so, i did make && make install, etc

font/source: … quirements

and all right!
i’m using centos 6.5 last kernel and kernel-devel and try too 6.4 and 6.3
now it is work pretty well in all.

sorry my bad english, any thing call me :wink: