Configuration asterisk

hello I have a problem I have installed without any problem and without any asterisk error on a virtual machine precisely on vmware workstation. (for testing purposes)

I followed the guides on youtube I looked at the guide several times and I did as it was told. The result is that to many users it works to me it doesn’t :frowning:

The internal network is parameters inserted in the sip.conf file in the localnet entry.

I copied and pasted the contents of the extensions.conf file attached in the youtube guide and pasted in the extensions.conf

Finally I created the default users 7001 and 7002 with password in the voicemail.conf file.

In the guide it refers to connect the host machine on which the virtual machine rests through the microsip program. I set the parameters:

Account name: 7001 (ip virtual machine on which there is asterisk)
User: 7001
Domain: (I don’t know what to put as the machine is not in domain I tried to put the right hostname for …)
Login: 7001
In the sip settings I also put as port number 5060 the one used by asterisk but it doesn’t go.

It always gives me as an error: request timed out.

What can I check?

Yes, we know all YouTube Asterisk videos and can immediately tell you what is going wrong, provided the original language is Albanian.

A more reasonable approach would be to look at Hello World - Asterisk Project - Asterisk Project Wiki or, except that once you are comfortable with the basic stuff, you should move to the newer PJSIP stack.

in fact the command sip show does not exist and in the guide there was. I saw the pjsip file So looking at all the guide will I be able to configure? That is, is there an order in things? In addition to the guide, is there a reliable site with laboratories?

Hello, what software are you using as the VM? Is it ESXI?

vmware workstation i tried both bridge and nat mode but it doesn’t work. There is obviously something wrong with the configuration.

None of these are official. You are expected to do make samples, during he installation, and take your first steps from the sample files. extensions.conf has some live test extensions, like fixed messages and echo applications. pjsip.conf does require you to uncomment some lines and adjust them for your network.

You want to get basic calls working first. I’m wondering if you are confusing the password in voicemail with the secret in sip.conf. chan_pjsip avoids that confusion by using password, as the parameter name.

Asterisk doesn’t check the domain on registrations, but it needs to be present.

You should either omit the proxy or make it the Asterisk IP address.

I would disable public address logic, assuming eh phone is on the same LAN as Asterisk, until you have local calls working. If it isn’t on the same LAN, you really should start with a configuration where there is no NAT between phone and Asterisk, as NAT causes a lot of problems and you want to have something that basically works, before trying to account for it.

The timeout means that you have routing, NAT, or firewall problems or are providing the wrong server or proxy details. It probably means that you aren’t even reaching Asterisk. However, generally, when starting, you should issue the CLI command core set verbose 5, and look at what is happening in the logs.

As for the passwords I have not confused them in sip.conf I have the following:
type = friend
host = dynamic
secret = 7001
context = internal.

In the voicemail.conf file I have always left 7001 => 7001 for the moment and then I use these credentials through the microsip application.

As for the test files in the youtube tutorial he made me create copy files of these three voicemail and sip extensions and I worked on these.

For the moment the phone is on the same LAN. Or rather the tutorial foresees that my HOST computer itself is a sip client for the sip server which is installed in a vmware workstation virtual machine. To get it right I’m doing everything on my pc as a test. So I set up a bridge connection on vmware that connects the virtual machine to the same lan as the sip client.

At the moment the evidence points to the problem arising before Asterisk has been reached. Until you can provide evidence, from its logs, of Asterisk receiving the register request, you need to look at the phone, network, and the firewalls and the Asterisk machine.

Hi I copied the code in the “hello world” section of the link, in the files I tried the connection and it doesn’t work. It was a test connection but it should have worked anyway.

You need to show us the complete configuration and a complete SIP trace of a failed call. Otherwise we can only guess.

I copied everything as it stands here Hello World - Asterisk Project - Asterisk Project Wiki If I copy and paste the files it is practically the same thing. In fact in the guide it is written not to worry about the meaning I will find out going on; it is written of a and paste the code in the files as said after creating backups of the existing ones I have performed as per procedure.

I do not know if you can attach the files here, I am attaching them, you tell me

The part that you have copied is likely not the problem, but something else. You can paste here fairly long texts (as preformatted text), but you should focus on the problem.

Understood where would you recommend me to start? Perhaps an indication I could give it. In the tutorial the guide does not say to put the ip address of the sip server in one of the files. As a neophyte I think that in asterisk there is a need to indicate the ip address from which then listen on a port in the tcp connections

My suggestion would be to start on the first page of . This is not about setting a couple of options, you have to learn and understand the underlying protocols.

If you don’t want to do that, then FreePBX might be more suitable. In case you are trying to do non-standard stuff, then FreePBX might turn out to be more difficult because you have to learn the inner workings of FPBX as well as the general SIP stuff and figure out how make things work together.

Ok thanks so there is some training to do anyway with freepbx can I make calls for free in the free version or do I have to buy a license?

As with raw Asterisk, if you want to make a call through the PSTN, you will need to pay an Internet Telephony Service Provider, or other network operator, for that service, but the basic calling features of FreePBX are included in the free version. What you lose are generally call handling features and configuration tools that are desirable to business users.

(FreePBX is not designed for direct to destination SIP, but nearly everyone blocks that, anyway.)

1 Like

So assuming that the configuration I made of asterisk is right, it is likely that it does not work for me also in my local home network in the lab I made (virtual machine where there is asterisk and host computer where I have the sip client), because Is my router provided by the provider blocking this type of service? Think I also disabled firewalls on both linux asterisk and on my windows machine it doesn’t work and the configuration I think is that.

So it is not enough to have an internet connection but you must also pay the provider for a separate service. While with freepbx this is not necessary correct me if I’m wrong

To make a phone call to a PSTN number (including a PSTN number which is routed to a SIP phone, or PABX), you need to pay a service provider. That is true for both raw Asterisk and for FreePBX.

To make a call directly to another SIP PABX, on the internet, you don’t need to pay for anything other than your internet access. However, in almost every case your call will be rejected by the recipient. This is true for Asterisk. Doing so for FreePBX is difficult, because FreePBX has assumptions built in that all calls to unconnected third parties will go through the PSTN, however it is probably possible, in the unlikely event that you can find someone to take the call.

Incidentally, even the PSTN is moving over to actually being SIP, in many countries.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.