Compiling zaptel drivers on Gentoo 2005.1


#1

Hello all, I am trying to compile the zaptel 1.0.9.2 drivers on a gentoo 2005.1 box and when I modprobe zaptel I get the following error.

root@drl ~ # modprobe zaptel
FATAL: Error inserting zaptel (/lib/modules/2.6.14/misc/zaptel.ko): Unknown symb
ol in module, or unknown parameter (see dmesg)

At the bottom of my dmesg output I get the following
output from dmesg: zaptel: Unknown symbol crc_ccitt_table
I have compiled the same tar ball on a fedora core 2 box and all drivers seem to compile fine. I am not using the gentoo-sources kernel just a straight 2.6.14 vanilla kernel from kernel.org.
I have included the output from emerge --info below.

Any help on this would be appreciated.

Thanks,

Doug

Gentoo Base System version 1.6.13
Portage 2.0.51.22-r3 (default-linux/x86/2005.1, gcc-3.3.6, glibc-2.3.5-r2, 2.6.14 i686)
=================================================================
System uname: 2.6.14 i686 Pentium III (Coppermine)
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium3 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium3 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo http://mirror.datapipe.net/gentoo http://adelie.polymtl.ca/ ftp://130.207.108.135/pub/gentoo ftp://130.207.108.136/pub/gentoo"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 accessibility alsa apache2 apm ares authdaemond bash-completion berkdb crypt cups curl curlwrappers devfs26 doc encode flash force-cgi-redirect fortran ftp gd gdbm gentoo-webroot-default gif gmail gmailtimestamps gstreamer jpeg libwww mad mbox mcal memlimit mp3 mysql mysqli ncurses nls nntp no-suexec ogg oggvorbis opengl oss pam pdflib perl php png python quotas readline samba sasl sdl sftplogging slang slp speex spell sse ssl tcpd threads tiff truetype udev vhosts vorbis xml2 xmlrpc zaptel zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTDIR_OVERLAY

[/code]


#2

I am getting the same error:

when i run:

wanrouter hwprobe
or
modprobe zaptel

I get the following error:

And in my dmesg i have the following

I am running Dual AMD Opteron 2GHZ, 2GB ram.
Gentoo 2005.1

with asterisk sources off digium site.


#3

crc_ccitt modules were missing

Go to /usr/src/linux

Type

make menuconfig
go to library routines

enable CRC-CITT functions and CRC32c

save and exit

Type

make modules
make modules_install

You should be able to launch wanpipe without re-installing it.


#4

[quote=“netjunkie”]crc_ccitt modules were missing

Go to /usr/src/linux

Type

make menuconfig
go to library routines

enable CRC-CITT functions and CRC32c

save and exit

Type

make modules
make modules_install

You should be able to launch wanpipe without re-installing it.[/quote]Thanks, I’ve got that part figured out now. I can now see my x100P channel.

Doug


#5

for anyone who has faced this problem and has made changes to CONFIG_CRC_CCITT in their kernel configs but still seems to have the same problem.

Well i have noticed that they must be configured as modules rather than built into the kernel.

the following change will still cause errors as it only makes the change visible to the kernel, but not to programs compiled outside the kernel.

CONFIG_CRC_CCITT=y
CONFIG_CRC16=y
CONFIG_CRC32=y
CONFIG_LIBCRC32C=m

After hours of frustration i realised my silly error and compiled it as a M (modular) and hey presto.

The following works, although may look the same as the config above it is quite different.

CONFIG_CRC_CCITT=m
CONFIG_CRC16=m
CONFIG_CRC32=y
CONFIG_LIBCRC32C=m