Comfortable transfers to fixed-length extensions without timeouts

Hi all…

Trying to make tansfers more comfortable…
System is Asterisk 16.

When doing in-call transfers first the appropiate feature code is
entered and then the destination number.
After that there is a waiting time of 3 seconds (transferdigittimeout) until
the transfer is started. (Or hit the # key to instantly start the transfer.)

Since all my extensions and ringgroups are 2-digit (20 to 68)
i’d like to take advantage from that.
The idea is to configure Asterisk so that it starts the in-call transfer
as soon as it recognized the second digit of the number.

This would be the advantages:

o Eliminates the need to press # or to wait for the
expiration of the additional 3 seconds timeout waiting time,
which is normally added by the timeout functionality.

o The 3 second timeout could be raised somewhat, without
sacrifycing performance if you enter digits fast.

I hope that there is an configuration option for this, which
i don’t know…

If not, can someone point me in the right direction for changing
that behaviour?

mani

The code is already written to work like this. If it’s not possible for any further extension to match then it immediately stops and doesn’t wait. I’d suggest you use “dialplan show” to examine the context and ensure that your assumption about what extensions are present is correct.

I also answered this at Transfers to fixed-length extensions without timeouts possible? - #2 by david55 - General Help - FreePBX Community Forums although concentrating on the 3 second timeout part.

hi jcolb,
i tried your suggestion “dialplan show”, but the output was huge (because FreePBX?) and i could not find longer than 2-digit extensions.

i testet transfers to extensions 43 and 59. got always 3 second timeout until transferred.

So i checked freePBX settings again.

My extensions are 20-59, ring groups 80-89,
a misc application with feature code *8899.
In extensions_custom.conf i have this:

[from-internal-custom]
;exten => *tr99,hint,PJSIP/FritzBoxTrunkXXXXXX ; Hint für Trunk frei = gruen
;exten => *tr99,1,Hangup()

exten => 55,1,Set(VOLUME(TX)=1)
;exten => 55,1,Set(VOLUME(RX)=3)

;Soundtests auf 99
exten => 99,1,Answer()
same => n,Hangup()

exten => *8192,hint,(Local/channel_1@LocalChannelContext,) ; Hint
exten => *8192,1,Dial(Local/channel_1@LocalChannelContext,) ; Dial den local channel

[alarm-anrufe]
exten => 60,1,Answer() ; called by www php script
exten => 60,n,Wait(1)
exten => 60,n,Set(LANGUAGE()=de_DE)
exten => 60,n,Playback(alarm/alarm-intro)
exten => 60,n,Hangup()

That’s all, i think.
So i don’t see where more extensions could exist that start with 43 or 59 that enable the timeout time.’
what else could it be?

I don’t know how that dialplan is organized, or what context is being used since FreePBX is in use. I can only go by what the code implementation indicates.

i just found out that the setup allows me to transfer to an external (longer) number.
that could be the reason for allowing longer than 2-digit numbers.
since i don’t need transfers to external numbers, can i disable this somehow?

Oof, I accidentally edited my previous comment. Odd. I didn’t even notice. Let me undo what I’ve done to bring order back to my train of thought.

That’s a FreePBX question. Asterisk itself has no concept of “external” numbers. It’s all based around the dialplan configuration.

could you help me if i post a file with the outputs of “dialplan show” ?

Not really. I don’t speak FreePBX, so I wouldn’t be able to tell you how to configure/change FreePBX.

Well, i still have no solution, but i made a test. in my single outbound route i changed the dial pattern matching filter temporarily from XX. to XX, thus accepting only 2-digit numbers.
And the timeout is gone. in-call transfers start immedialtely after entering the second digit, just like you said.

now i have to figure out how to setup FreePBX to disable outbound transfers and make Asterisk “see” that…

got it working:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.