CodeBarring Issue With PRI-Gateway

we have pri-gateway that delivers pri to customer using sip protocol. we are using this gateway as pri_net. customer connect their traditional pbx and use the pri. we are having issue with code-barring. code barring works fine it customer connect their pbx to some telecom switch i.e alcatel e10 or other switched. but wen they connect to our pri-gateway code barring does not work. it behaves as follow with different exchanges.

  1. code barring does not work at all and pbx extensions are able to make calls.
  2. code barring work and pbx extension are unable select the trunk. that means their all calls become restricted.

thank for you support.



I am having the same issue

Do you need extra digits passed through your dial plan ? Like #55#0900# would enable toll 0900 number calling on the line ?

You might consider changing your dial plan from something like:

exten => _X.,n,Dial(SIP/abc/${EXTEN})

To maybe add:

exten => _#XX#XXXX#,n,Dial(SIP/abc/${EXTEN})


exten => _#X.,n,Dial(SIP/abc/${EXTEN})

The trouble is the leading X in the pattern match in the first example would only match digits 0-9 and not * or # or + or what ever else is being sent by the legacy PBX.

No, Its not like that.
We have an Alcatel Omni PCX connected via digium E1 card connected to asterisk box. Problem is when code barring is enabled on Alcatel Omni PCX, it does not work. When Alcatel Omni PCX is connected to another E1 which is from a TDM source, it works perfectly.

Seems like some signal is passed by PBX which asterisk is unable to understand.

This problem is resolved by adding overlapdial=yes in zapata.conf.