Cmd MYSQL connect fails

Asterisk 1.4.4
Add-on 1.4.1

cdr_mysql… working fine
res_mysql… working fine
cmd MySQL… fail on connect

on startup
CLI: => (URI encode/decode dialplan functions)
== Registered application 'MYSQL’ => (Simple Mysql Interface)
== Registered application ‘SayCountPL’

on execution

Executing [3028@payphone:1] MYSQL(“SIP/1001-08265780”, “Connect connid localhost asterisk asterisk shortcut”) in new stack
[May 7 19:10:13] WARNING[24251]: app_addon_sql_mysql.c:234 aMYSQL_connect: mysql_real_connect(mysql,localhost,asterisk,dbpass,shortcut,…) failed


[May 7 19:13:05] WARNING[24283] app_addon_sql_mysql.c: mysql_real_connect(mysql,localhost,asterisk,dbpass,shortcut,…) failed

cpan> install DBD::mysql
CPAN: Storable loaded ok
Going to read /root/.cpan/Metadata
Database was generated on Sun, 06 May 2007 00:14:37 GMT
DBD::mysql is up to date.

Mysql working fine:

root@core:/var/log/asterisk# mysql --user=asterisk --password=asterisk
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 194
Server version: 5.0.37-log Source distribution

Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the buffer.

mysql> use asterisk;
Database changed

Where is the problem ?


My mistake

Problem solved.

One day somebody with the same problem as yours will get all excited seeing your post. What a let down it will be when they see you fixed it, but don’t say how you did it… :frowning: