CLIP does not work

As a technician of a beginning VoIP business company, my task is to use asterisk for managing outbound calls. Everything works well for 2 months, except a few annoying issues.

We have two different providers for outbound calls. Unfortunately, CLIP (Calling Line Identification Presentation) does not work for both. The first one shows “hidden number”, the second one shows “unknown number” for the called party when the call is established.

I tried to fine tune the settings in Asterisk. We work with SIP protocol only, so as I figured out from the docs, no editing in zapata.conf is needed. What I did is to edit extensions.conf and tried all possible statements as described in the following docs: … CallerPres

The Asterisk logs cannot tell me any problems with the suggested commands, i.e. I get the following debug information within the command line interface:

– Executing SetCallerPres(“SIP/”, “allowed”) in new stack
– Executing Set(“SIP/”, “CALLERID(num)=12345678”) in new stack
– Executing Dial(“SIP/”, “SIP/prov1/987654321”) in new stack
– Called prov1/987654321
– SIP/prov1-081b6b98 is making progress passing it to SIP/

I also tried to edit the sip.conf file with callerid=12345678 but no success with that, too.

Please help! Has anyone experience with such a problem?

Thank you in advance. (I am using Asterisk 1.2.13 in Debian 4.0 Etch.)