Choppy MOH w/Update to *-1.4

I run FreeBSD-6.1 and have *-1.2.13 running swell. The moh has been one of my favorite toys even though I only setup a special extension and dial into it using my Grandstream SIP phone and use it as mp3 player…this runs on an old P166 with only 96M of RAM but it does okay.

So today with some spare time on my hands I built another drive with FreeBSD-6.1 on a really screaming AMD 2.0 Ghz machine and installed all the dependencies for * but then instead of using the ports I built *-1.4.0-beta3 from scratch. To my surprise it worked okay and when I copied over my existing conf files it was off to the races. So I then kldload zaptel, ztdummy etc… and tried to use the moh and MeetMe functions.

  1. The moh works but it’s choppy as can be…this is really strange because it’s a much faster machine and it’s on the same LAN. The generic gsm files were okay but my mp3 collection that plays so well on the other, slower machine are all chopped up. Also I couldn’t get the mp3’s to play using the mode=files. I had to switch to mode=mp3 or mode=mp3quiet to get these files to play. I didn’t have to do that on the other machine.

  2. The meetme conference rooms don’t work at all. I get this message when I try to access a conference room:

[Nov 24 21:01:02] WARNING[25571]: pbx.c:1755 pbx_extension_helper: No application ‘MeetMe’ for extension (special, 1236, 1)

I didn’t change anything in my conf files with the exception of the musiconhold stuff. All other files were left intact as they were on the machine that runs all this same stuff okay with *-1.2.13.

Can anyone tell me what I’ve done here…I really want to try out the new gui with 1.4. Also, I was surprised that it got this far. The difference in the file locations from linux to FreeBSD is not so straightforward and the advice you get from FreeBSD users is even more snobby and obscure than what I get from linux users.

Okay…so sue me…I just noticed that the add-ons did not install properly. Again, I’m building from scratch and it got through the ./configure part but when I ran gmake it failed with Error 1.

I’m still trying here…more to come!