Changed sdp_session option in the pjsip.conf but it didn't work

Hi there,
I tried to change the “sdp_session” option in the “pjsip.conf”, but when i saved the configruation and performed a call, it seemed like that the “s=” was still “s=Asterisk”, not “s=test” which l changed in the “pjsip.conf”. I am sure that i changed it and saved it.
Any ideas?

Please share with us what you changed and unfer which settings/field

And also whether you reloaded Asterisk.

Thanks for reply.
My version of the asterisk is 16.16.1, which is installed in debian 11 by apt.
I have two hosts connected through the pjsip wizard. The settings are follows:
type = wizard
transport = transport-udp
endpoint/allow_subscribe = no
endpoint/allow = !all,ulaw
aor/qualify_frequency = 30
registration/expiration = 1800
registration/contact_user = tests
endpoint/contact_user = tests

endpoint/context = tests
remote_hosts = <IP>
sends_registrations = no
accepts_registrations = no
sends_auth = no
accepts_auth = no
contact_user = tests

In “pjsip.conf”, i changed these settings:



Did some of these settings are conflicted?

Thanks for reply.
Yes, i tried to reload module(, system(command reload) and the os(command reboot), but all of these action didn’t work for me.By the way, only “sdp_session” option didn’t work, and the rest works.

There’s no conflict, but you haven’t really configured things. There’s just a random category named “endpoint”. If you’re using wizards, you also can’t change things in pjsip.conf for it. You change it in the wizard configuration instead on the specific entry.

I see… So the “[endpoint]” section in “pjsip.conf” is just some help documentation for setting it?
I set “endpoint/sdp_session = test” in the “pjsip_wizard.conf” and it worked. But there were something wierd happend, let me use this picture below to explain it.

So, when i performed a call, the INVITE from asterisk A to asterisk B contained the “s=test”(same when from B to A), which worked well. But the INVITE from asterisk to softphone is still “s=Asterisk”, which really confused me. Is there any other settings to change this? Or maybe this is protocol problem which can’t be changed?

endpoint will be a meta name. That part of the sample is trying to list all possible options, but the realistic content of the section, which actually would include a type=endpoint line, is given earlier.

Personally I find it much easier to debug configurations if the wizard isn’t used.

The soft phone is a different endpoint. The wizard.conf your gave above only has settings for trunks.

Each endpoint configuration is independent. You probably set it on one, but not another.

Thanks for your reply.
Yes, my softphone endpoint is defined by realtime database, after i updated the sdp_session column, it works very well. Your answer also solved my confusion about setting asterisk, thank you very much.
Have a good day!

Yes, you are right, i forgot to change the softphone endpoint. Thanks for your help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.